tylerdurden2

All AMD Drivers, Win 7 x64: COM Surrogate has stopped working!

Discussion created by tylerdurden2 on Aug 11, 2017
Latest reply on Aug 14, 2017 by tylerdurden2

Hello all

 

I have a big problem installing AMD Drivers both for the new X370 chipset for AMD Ryzen

in Windows 7 x64 SP1, as well as for an AMD Radeon graphics card RX470 by MSI:

 

I have an ASRock Fatal1ty X370 Gaming K4 motherboard with an AMD Ryzen 1500X CPU

and a MSI Radeon RX470 Gaming X, 4GB graphics card.

On this system I can install Windows 7 SP1 x64 with no problem. But when I try to install

the AMD chipset drivers OR the AMD graphics card drivers, I always get the following error

message popping up at least once, usually several times, usually freezing (crashing) the

installers:

--------------------------

COM Surrogate has stopped working
Windows can check online for a solution to the problem the next time you go online.
--> Check online for a solution later and close the program
--> Close the program
[Down Arrow] View problem details
--> Details:
Problem signature
Problem Event Name:           APPCRASH
Application Name:                DllHost.exe
Application Version:             6.1.7600.16385
Application Timestamp:      4a5bca54
Fault Module Name:             ole32.dll
Fault Module Version:          6.1.7601.17514
------------------------------------------

The funny thing is, it doesn't always happen at the same point.

At one point or the other, I had a completely normal appearing installation

of EITHER the chipset drivers OR the graphics card drivers. Just

never ever both. The error always occurs at least once, usually several times

and it usually hangs the installer.

But even when one or the other installation seemed ok, of course I don't know

if everything installed successfully behind the surface. I have tried clean uninstall

several times and there, I noticed, that no USB 3.0 or USB 3.1 drivers were

ever available for uninstallation, despite that 3 or 4 such drivers are installed

and are individually selectable during installation. So it appears it doesn't install

those drivers at all.

 

I tried this on several Windows 7 SP1 installation attempts, tried clean uninstall

and even on two different, identical motherboards, one with BIOS P1.60, one

with BIOS P2.10.

I tried the chipset driver version 16.50 which came with the motherboard

setup DVD, as well as the newest version downloaded here, version 17.10

(amd-chipset-drivers-software-17.10rcp22-apr27.exe, 196'826 KB).

Same with the graphics card driver, I tried the driver supplied on the original

purchase setup-DVD (I think it was like version 16.30 or something), as well as

the newest version downloaded from AMD here

(whql-win7-64bit-radeon-software-crimson-relive-17.7.2-july27.exe, 478'647 KB).

Nothing helps.

 

What's going on?

I specified Windows 7 x64 as my operating system when I downloaded the

drivers, yet they fail to install correctly on my Windows 7 x64 SP1 system.

Is this a bug AMD is not aware of yet?

It seems like their installers are buggy. Or is this a problem in my Windows?

Should I try to update Windows before trying to install the AMD drivers?


Please help!

 

EDIT: I finally figured it out: After several days of testing and re-installing:

The AMD drivers are not compatible with basic Windows 7 SP1 x64

setup. They require your Windows 7 to have been updated after SP1.

I did the full Windows 7 Windows Update and after that, all AMD

drivers install flawlessly. Without the Windows Updates, the AMD

drivers will crash or hang. Obviously Windows Updates adds some

files or drivers, etc. (perhaps .NET components) which the AMD drivers

or installer requires. This seems to be a problem of AMD, as an

installer for drivers should be able to handle a fresh installation of

an operating system. And I don't even just mean without Windows

Updates, but basically even without SP1!

Seemls like AMD took a shortcut when programming its installers

and just checked them on a fully up-to-date Windows 7 installation

instead of a fresh and new basic install! Badbadlousy!

Outcomes