11 Replies Latest reply on Nov 26, 2017 12:56 PM by pejantan

    How to disable Wattman?

    edman201

      As much as I am happy with all AMD's progress at the same time I am starting to get annoyed by this feature. It's constantly down clocking my GPU to lowers frequencies than originally offered. I can't even try to OC the GPU using the software provided by the manufacturer, every time I attempt to run any of the default modes I get an automatic down clock; only setting I can use are the GPU's fan controls. I am getting terrible performance from this problem, I was satisfied with the performance I was getting from my R9 390X "Until the release of VEGA". Can this feature either be removed or disabled from Radeon's software or at least make it possible.

        • Re: How to disable Wattman?
          whiskey-foxtrot

          I'm curious about the down clocking - Can you post what you're trying to set your card at and which OS and driver version you're using? Are you perhaps going beyond the Power Limit settings or that cards specific limitations causing it throttle - or perhaps vendor based software causing conflicts?

           

          Since the introduction of WattMan I've never looked back at using other software, especially vendor provided options. They (vendors) are either slow at following up with subsequent Radeon driver updates or they completely abandon support. So far I've been enjoying all the improvements AMD's Radeon team has made with updates - even with the occasional frustration at times!

           

          I no longer have any R9 390's left or I'd try to duplicate it; if it is something you can duplicate, I would report it through the main website (or using the handy dandy built-in reporting tool in Radeon Settings).

            • Re: How to disable Wattman?
              edman201

              Regarding the down clocking, I have the Asus Strix r9 390x DC3 which boost a default "GAME MODE" clock speed of 1070 Mhz on the GPU Clock and 1090 Mhz on "OC MODE". ever since Wattman those clocks are automatically down clocked to 1020 Mhz regardless of the mode I select. On top of that you are unable to even use any other settings aside from the fan speed, otherwise the software will crash "Asus GPU Tweak". This down clock is causing mayor FPS drops, Stutters and excessive diminishing performance in every game I run.

            • Re: How to disable Wattman?
              benman2785

              i highly doubt that Wattman downclocks your GPU when its set properly

               

              check if your GPU has correct BIOS - if you bought it secondhand online it may used a MINER-Bios - simply flash a correct BIOS first

               

              1. flash correct BIOS
              - if not working -
              2. set GPU & RAM clock manually in 'WattMan'
              3. raise 'Power-Limit' to min +25% - have in mind - your GPU will stay clock-stable until it either hit thermals or power-limit - so it will most likely prevent your GPU from "losing" performance, yet you have higher power-draw
              4. hit apply

               

              btw with 17.7.2 i cant use MSI Afterburner for OC

              1 of 1 people found this helpful
                • Re: How to disable Wattman?
                  edman201

                  I've been the only owner of the card; ever since I bought it has been used specifically for gaming. I had to uninstall the tweak software. I still get an error where the GPU stops working and games suddenly crash... just the games!. I don't need to add more power since the card its suppose to run @1070Mhz out of the box and it is being down clocked to 1020Mhz cause of Wattman. I will have to manually setup Wattman to the cards default settings, if Wattman allows me too.

                • Re: How to disable Wattman?
                  edman201

                  Here is a picture of what all this is causing my rig every time I game on it... ever since the latest driver update.

                   

                  GPU error.jpeg

                  • Re: How to disable Wattman?
                    benman2785

                    you dont understand what power-limit does...

                     

                    a GPU downclocks itself on its own when it hit either of this 2 limits - thermals or power-limit
                    but with a good cooler your GPU will most likely run into Power-Limit - so when you raise that your GPU will hold its clock instead of downclocking when hiting standard power-limit

                     

                    ---

                     

                    btw your error looks like a faulty GPU or faulty driver

                     

                    reinstall your system completely - check again

                    • Re: How to disable Wattman?
                      benman2785

                      faulty driver install

                       

                      1. download 17.7.2 again
                      2. delete C:\AMD\WHQL-Win10-64Bit-Radeon-Software-Crimson-ReLive-17.7.2-July26
                      3. use latest "DDU" as admin in "SAFE MODE" - your pc will restart - deinstall driver in safe mode choose "clean and restart" - pc will restart again

                      4. install 17.7.2 again

                      5. restart

                       

                      test again

                      • Re: How to disable Wattman?
                        kiptanoi

                        Where is the answer on how to disable or remove wattman?