38 Replies Latest reply on Aug 11, 2017 6:27 PM by archdevil155

    Can't uninstall driver/amd software in safe mode (complicated)

    archdevil155

      Hello, I did something I regretted shortly after I did it. -Windows 7, latest AMD drivers, R9 380 graphics card- I just installed Dishonored 2 and wanted to check the setting in the amd software, not in the game, to get it to play in windowed. The important thing so far is that I opened the amd software. In there I started looking around, discovering what settings there are. I clicked on most of them to see what options I have and as a result I clicked on "Scale GPU" turning it on. I didn't know what it did (still don't) nor did I know that I wouldn't get to choose between options, that something would be activated right away and I wouldn't get a chance to revert. After that my screen went black and the classic "Out Of Range" message appeared. Every time I turn on my pc of course the setting is still there so I can't do anything. I started it in safe mode to try and change the setting back, but when I tried to open the software, it said that I had to install my graphics card first or something like that. Next, I tried to go to Programs And Features in safe mode to uninstall "AMD Software". It seemed to start normally but the progress bar filled only to about 10-15% I'd say, and then didn't go any further. After some time I clicked "Stop Uninstallation", the app window showed "Please wait until the uninstallation is finished" or something similar, and again didn't go any further. So to me it seems like I can't uninstall the software and I can't change the Scaling setting. So pleaaase tell me, what can I do to get it back to normal? Also, why isn't there that classic resolution thing that once you make a change it says "the settings will revert back in 30 seconds" (or 15 or w/e) and you have to choose "Keep current settings" in order to not revert??? This kind of thing is exactly why that classic resolution thing is oh so very useful! I hope the minds and the kindness of this online community provide me with a solution soon. Thank you, to anyone who checks this out even if you can't make a good suggestion.

       

      Edit: When I try to open the AMD software, the message it actually gives me is the following:

      No AMD graphics driver is installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate for your AMD hardware.

      Could this mean that the uninstallation proceeded enough to make the driver not function properly? Or is it that in safe mode it doesn't really load the driver?

       

      Message was edited by: Spiros Pagiatis

       

      Edit #2: I downloaded some older driver (17.1.1) to see if I can install that one and then maybe successfully change the setting or uninstall the AMD software, but when I tried to install it, I got an error (error 99) saying that the driver was not digitally signed and therefore couldn't be installed. I also downloaded the minimal setup option from the AMD drivers to try the same thing I mentioned just above, but when I tried to run it it said it is not compatible with the version of Windows I'm running and that I should check to see if I have x64 (64-bit) or 86x (32-bit) and contact the software publisher. I didn't mention this before, but I have 64-bit.

       

      Message was edited by: Spiros Pagiatis