AnsweredAssumed Answered

Help with Ubuntu 16.04.2 + AMDGPU PRO 17 install

Question asked by devpake on Aug 8, 2017
Latest reply on Aug 8, 2017 by devpake

ASROCK E3C224 / Intel i3

MSI Radeon RX580

Ubuntu 16.04.2

AMDGPU-PRO-1.7.30-458935

 

Trying to install the drivers on a clean install of Ubuntu 16.04.02.  Basically just followed the AMD instructions How-To Install/Uninstall AMD Radeon™ Software AMDGPU-PRO Driver for Linux® on an Ubuntu System  but running into a snag where installer can't find a package (yet, I see that it's there).

 

Here's the output that I get from the installer:

 

Hit:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Get:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 DEP-11 Metadata [305 kB]
Get:6 http://security.ubuntu.com/ubuntu xenial-security/main i386 DEP-11 Metadata [59.8 kB]
Get:7 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [55.4 kB]
Get:8 http://security.ubuntu.com/ubuntu xenial-security/universe i386 DEP-11 Metadata [48.7 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [207 kB]
Get:10 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [64.2 kB]
Get:11 http://security.ubuntu.com/ubuntu xenial-security/multiverse i386 Packages [2,908 B]
Get:12 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe i386 DEP-11 Metadata [170 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [220 kB]
Get:14 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse i386 DEP-11 Metadata [7,056 B]
Get:15 http://us.archive.ubuntu.com/ubuntu xenial-backports/main i386 DEP-11 Metadata [3,324 B]
Get:16 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe i386 DEP-11 Metadata [5,136 B]
Fetched 1,455 kB in 5s (284 kB/s)
Reading package lists... Done
deb [ trusted=yes ] file:/var/opt/amdgpu-pro-local/ ./
Get:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Ign:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Get:2 file:/var/opt/amdgpu-pro-local ./ Release [814 B]
Get:2 file:/var/opt/amdgpu-pro-local ./ Release [814 B]
Get:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg
Ign:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg
Get:4 file:/var/opt/amdgpu-pro-local ./ Packages [72.4 kB]
Hit:5 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Hit:6 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:7 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:8 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package amdgpu-pro-lib32

 

The last line mentions my problem.

 

I did some digging and am finding that APT is not listing the package as part of the repository for whatever reason.  amdgpu-pro is ok.  But amdgpu-pro-lib32 is not recognized even though I see it in the Package list and the actual package is in the source location.

 

Any hints as to where I should look to resolve this?

 

Thanks

Outcomes