AnsweredAssumed Answered

AMD Radeon R7 graphics + R8 M435DX -> Driver is updated but when I try to open the Radeon Settings app, it says that no AMD driver is installed

Question asked by gabolt on Aug 6, 2017
Latest reply on Sep 23, 2017 by megahellsing

I recently bought an ASUS-X555Q notebook a few days ago. It has an AMD Radeon R7 Graphics + an AMD Radeon R8 M435DX card (2 GB total).

 

Recently (2017-08-05) I got a notification from ASUS there was an update for the AMD Radeon graphic card (The update was successful)

 

Whenever I try to open to Radeon Settings (desktop app) I get the error: "No AMD graphics driver is installed or the AMD driver is not functioning properly"

(PS: I did not attempt to open the app before I got the ASUS AMD driver update notification).

 

I went to AMD's website and got the auto detect software and tried to update my driver, and it notified me that I already had the most current driver installed.

 

I then tried via my Device Manager to first update the R7 driver (the install worked), then I attempted to update my R8 (it failed while installing: Code 43 from Windows appeared).

 

On my computer settings I only see 1 GB dedicated to graphics instead of 2 GB (please see the attached files).

 

How do I fix this?

Thanks

 

Gabe

Outcomes