AnsweredAssumed Answered

nothing above 1440P after 17.7.2 update?

Question asked by gwenwolf on Aug 4, 2017
Latest reply on Aug 14, 2017 by ray_m

I 'am back again

My R9 Fury's have worked above 1440P for a while now. It wasn't perfectly correct but I was some what happy. Now after this 17.7.2 update I no longer can play any game or set my desktop to 2160P or anything above 1440P. My screen breaks up into long up and down white lined squares with weird discolored box formations behind the up and down white line boxes.. rendering a messed up picture that's unreadable. Just wanted to know if this is a glitch by AMD or are they limiting us via the drivers? Anyone else have this issue and if you fixed it please tell me so I can play the games at 4K again...thanks in advance.


MSI SLI PLUS X370 motherboard

Rysen 1700 @ default

32 GB DDR4 @ 2993 Mz

2 - R9 FURY'S  No Crossfire

1000 Watt PSU Platinum

Win 10 64/Bit updated & latest Mobo Bios  7A33v34

3 - Drives Blu-Ray/SSD/Mechanical

Full tower with tons of fans