5 Replies Latest reply on Aug 14, 2017 4:04 PM by ray_m

    nothing above 1440P after 17.7.2 update?

    gwenwolf

      I 'am back again

      My R9 Fury's have worked above 1440P for a while now. It wasn't perfectly correct but I was some what happy. Now after this 17.7.2 update I no longer can play any game or set my desktop to 2160P or anything above 1440P. My screen breaks up into long up and down white lined squares with weird discolored box formations behind the up and down white line boxes.. rendering a messed up picture that's unreadable. Just wanted to know if this is a glitch by AMD or are they limiting us via the drivers? Anyone else have this issue and if you fixed it please tell me so I can play the games at 4K again...thanks in advance.

       

      MSI SLI PLUS X370 motherboard

      Rysen 1700 @ default

      32 GB DDR4 @ 2993 Mz

      2 - R9 FURY'S  No Crossfire

      1000 Watt PSU Platinum

      Win 10 64/Bit updated & latest Mobo Bios  7A33v34

      3 - Drives Blu-Ray/SSD/Mechanical

      Full tower with tons of fans

        • Re: nothing above 1440P after 17.7.2 update?
          kenyomurabu

          What is your Monitor's Resolution & Size?

           


          This also has to do with how much your GPU can Upscale an Image, through Super Resolution...

           


          So what is your Monitor's Resolution & Size?

            • Re: nothing above 1440P after 17.7.2 update?
              gwenwolf

              Hi! and thanks! for responding to my question. I have been using a Westinghouse 40" 1080P 120 hertz LED TV I have always been able to scale to 2160P Even when I was Using Nvidia's cards. My Fury has always had it's issues but I have always manage to find it was a driver issue. This has to be also I assume as it was working correctly with drivers 17.5.2. After a clean install I can not display anything above the 1440P resolution. I can create most common resolutions and even the ones provided are not allowed above 1440P in VSR. I am going to retry another clean install using third party driver cleaner. I hope it helps me out.

              • Re: nothing above 1440P after 17.7.2 update?
                gwenwolf

                It appears I have found the problem. The AMD drivers do not properly remove the old drivers. I tried their clean install feature on the AMD drivers. They appeared to work properly prier to 17.7.2, so I got rid of my DDU third party driver software remover.. relying on AMD's own removal process caused the error. This is a lesson again I have to learn. I feel a bit foolish and a bit lost for words... sorry to have even posted. Thank you again for responding to my question and I wish you the best of luck.

                Lesson of the day:   Do Not Rely On AMD's Removal Feature Built Into Their Driver Software. It Does Not Work Properly In Removing Their Old Drivers... Use DDU To Properly Remove Everything So Your New Installation Of The New Drivers Goes Through Smoothly. A Lesson I Had To Relearn......

              • Re: nothing above 1440P after 17.7.2 update?
                kenyomurabu

                Don't use Clean Install... It caused my Windows Boot Up Screen to turn Green...

                 


                I dunno how to fix that, but if you uninstall manually, & then Re-Install, it works better...

                • Re: nothing above 1440P after 17.7.2 update?
                  ray_m

                  MODERATOR NOTE:  I am glad to see you have resolved your issue. To help keep this post on topic and help other with a similar issue, I am locking this thread.