AnsweredAssumed Answered

Unable to use video editing software since I installed the latest AMD Driver for my RX 480

Question asked by emlan on Aug 1, 2017
Latest reply on Aug 1, 2017 by peccavi

Unable to use video editing software since I installed the latest AMD Driver for my RX 480

 

PC specs are:

  • Windows 7 Home Premium 64-bit SP1-
  • AMD FX-8370 - 16.0GB
  • Dual-Channel DDR3 @ 798MHz -
  • 8192MB ATI Radeon RX 480 Graphics (Sapphire/PCPartner)

 

The editing software is Lightworks Pro, which I have used for a couple of years with no issues. I last used it about a week ago and it was all fine.

 

Inbetween then, I installed the latest crimson / re-live driver as I was prompted to update. A couple of days later, when I have tried to use the video editing software, it will no longer display any videos.

 

I wondered whether there could be an issue with display driver so I installed all new windows updates, did a clean uninstall of display driver and reinstalled the driver.

 

Now when I enter the editing software, as soon as I attempt to view a video file, the whole display goes black for a second and I get a windows error message that the display driver stopped responding momentarily.

 

The same thing happens when I try to run a GPU test from within the Lightworks program.

 

I do not seem to be having any issues with any other applications. Video plays fine in VLC and on chrome.

 

I was able to boot up and run Witcher 3 at 60fps as normal.

 

I ran a benchmark test which the GPU passed as ok- although working below expectations.

 

I understand that the issue may lie with the Lightworks program itself, and I am trying to look into this also, but it does seem given the timing of the driver update + the error message about unresponsive display driver, that there may be in an issue with the driver itself.

 

Any help would be much appreciated.

Outcomes