3 Replies Latest reply on Aug 4, 2017 10:29 AM by ironhair

    AMD drivers not updating.. stuck on 8.840.7.3000

    ironhair

      I have an old laptop on which I have AMD Radeon HD6630M.

      I rather adventurously installed windows 10, post which I faced constant video driver problems.

      After about a year of not using the laptop, I finally restored the factory image and am back to window 7.

       

      Sadly, the BSOD still occurred.

      It was first with the atikmpag.sys, but after I updated that file (using the atikmpag.sy_ file), it started giving me igdpmd64.sys errors.

      I got the file from unzipping the install files > (AMD-Catalyst-15.7.1-With-DOTNet45-Win7-64bit\Packages\Drivers\Display\W76A_INF\B187676) and then using expand in cmd.

      As that wasn't working, I restored the earlier atikmpag file (which I had saved as .bak) but I was back at square one (atikmpag.sys BSOD).

       

      As I was unable to log in AT ALL, I decided to log in using safemode.

      That worked thankfully, but I was unable to install the AMD drivers as the detection driver error stopped me from installing the drivers.
      I then disabled the AMD driver using Windows device manager and finally managed to log into windows 7 normally.

      The AMD catalyst setup started, but I got an error at the end which said the display drivers have not been installed.

       

      Packages for install

      AMD Display Driver

      Final Status:Fail
      Version of Item:15.200.1062.1004
      Size:90 Mbytes

       

      On checking the amd driver details using Device Manager, I'm currently on 8.840.7.3000.

      I'm at a loss on how to proceed.
      Any help would be strongly appreciated.