2 Replies Latest reply on Aug 2, 2017 3:42 PM by ray_m

    How do I force AMD Radeon HD 8600/8700M as my preferred GPU for games over my integrated GPU?

    nathanitsnathan

      I have a laptop that came with two GPU's: one is integrated and one is dedicated. The integrated is Intel HD Graphics 4000. The dedicated is AMD Radeon HD 8600/8700M. I was told when I got this laptop that the AMD was a fantastic graphics card (mind you, this was four years ago). However, now that I have finally bought a computer game on Steam (Skyrim), at first it seems this isn't the case. It runs on horrible FPS and control delay on the lowest graphics settings possible. My guess is that the laptop is not recognizing that it needs to switch to the AMD GPU when I launch Skyrim and is instead using the Intel GPU. When I disabled the Intel GPU and tried to launch Skyrim, a message popped up saying it couldn't find any GPU in my system. This must mean that my system isn't detecting the AMD GPU at all (or at least Skyrim isn't). Note that both of my GPU's display that they are 'working normally.' Also note that I did download the driver/software necessary on AMD's website. When I go to 'AMD Settings' on my computer and go into the 'Games' tab, Skyrim is on there and it seems there are specific settings for the game that I can tweak. This tells me that AMD is detecting Skyrim..... but Skyrim must not be detecting AMD. How can I fix this?

       

      For the record, I will probably not be playing much Skyrim, but I would like to solve this problem as a whole in case I run into this problem with any other future games I buy. For example, I plan to buy Player Unknown: Battlegrounds soon and obviously don't want that to be running on my integrated GPU.

       

      Any and all help will be appreciated. Thank you!!