5 Replies Latest reply on Jul 24, 2017 1:07 AM by rebelyell

    My Radeon 390x 'skips' a frame about each second, making one frame visually twice as long.

    zedgraps

      As the title says, my Radeon 390x is constantly skipping a single frame even though I know it's not performance related.

       

      When I play Overwatch it is very noticeable especially when walking down corridors. The game notices it to; it reports 58 fps instead of 59/60.

       

      I know that it in not performance related because it happens in very simple games too. Take a look at this picture below, which is the profiler in Unity 3D in a completely empty scene with nothing to render. The white line is over one of the large green spikes; as you can see "Gfx.WaitForPresent" is the problem. Obviously there is nothing to see in this scene, but in a simple game I made in Unity it is very noticeable and annoying.

       

      Screenshot 2017-07-15 23.09.04.png

      The only game I haven't noticed this is an old 3D game from 1998, if that info is somehow useful. (But perhaps that game is actually set to render at 30fps)

       

      I've tried googling it and messing with settings with no luck so far. Currently I have vsync enabled (called "Wait for Vertical Refresh" in settings "Always On"), also I have it enabled in Overwatch for example with a target of 62 fps. Please help?