AnsweredAssumed Answered

Asus Rx 470 blackscreens then no signals

Question asked by fiveofeight on Jul 19, 2017

Computer Type: Selfbuilt desktop

GPU: Asus Strix-RX470-4g-gaming with Hynix vram. Stock frequencies and power curve.

CPU: Intel Core i7 4770k stock frequencies

Motherboard: ASRock Z97 Killer Fatal1ty

RAM: 2x 8GB Gskill F3-12800CL10D-16GBXL DDR3 ram 1600MHz 10:10:10:30

PSU: Corsair GS700

Operating System & Version: Windows 10 creator's update

GPU Drivers: Crimson 17.6.1

Background Applications: Any sort of 3d game such as Overwatch, WoW or Unigine Valley Benchmark


Description of Original Problem: After playing games for a few hours, my screen will go blank and then both my monitors say no signal (DVI an DP to VGA adapter are the two connectivity ports I use). I can still hear audio playing from whatever game I was playing, VOIP call I'm in or music I was listing to for around 30 seconds after the crash, after that it goes quiet. I have to hard reset the machine to get it to respond again. After rebooting sometimes event log will say "Application Wow-64.exe has been blocked from accessing Graphics hardware. The card does not appear to be overheating, hottest it ever gets is 72c and it seems to happen mostly when a game is running, I've tested mining Ethereum (with Claymore) and the system doesn't black screen like when playing a game. I have also tested just using the DVI monitor rather than both to make sure the DP-VGA adapter wasn't faulty.


Troubleshooting: I've put in my old MSI Radeon HD 5770 and used DDU to clean up the drivers, the issue does not present itself with the old card. I've used DDU to try different driver versions with the Rx 470, tried 16.8.3, 16.10.2, 16.11.5, 16.12.2, same result. Used the registry change to change the TDR to 8, no change. I tried dropping the clocks by 300MHz (1206 to 906 core and 1650MHz to 1350MHz for ram), and giving the card 15% more power, neither made any difference. I've tried putting it in a different PCI-Express slot on my main PC. I've put the card in another machine (Intel Pentium G 3220, Asrock H81M motherboard 700W thermaltake PSU, Windows 7 Home) and experienced the same black screen issue (was using 16.50 driver). I also tried Win+Ctrl+Shift+B to reset the graphics driver after I get a black screen, but this did nothing.


My display port ended up failing and I submitted an RMA to Asus with both issues listed and got the card replaced. The DP port works on the replacement card but the no signal crash issue is still present same as before.