2 Replies Latest reply on Aug 1, 2017 3:14 PM by ray_m

    Error Code 43 on Second RX470

    spyderturbo007

      I'm having some issues with a second RX470 I installed in a new build.  I started with one RX470 (Sapphire 4GB) and installed the drivers.  Everything worked just fine.  However, when I install the second RX 470 (Sapphire 4GB) everything goes nuts.  Windows 10 Pro x64 disables the secondary GPU with a Code 43 and won't allow a resolution above 800x600.

       

      The two Sapphire cards are slightly different, but I read that if they are both Radeon RX470's everything should work.

       

      SAPPHIRE Radeon RX 470 11256-31-21G 4GB GDDR5 PCI-E (UEFI) (Built with Samsung Memory) Brown Box Version - Newegg.com

       

      SAPPHIRE NITRO Radeon RX 470 DirectX 12 100407NT4GOCL 4GB 256-Bit GDDR5 PCI Express 3.0 CrossFireX Support Video Card - …

       

      Is it because they aren't exactly the same?  I'm glad I didn't pay those prices.  Yikes!

       

      I thought maybe I had to install the drivers when both cards were installed, so I ran the AMD cleanup utility, rebooted and re-installed the drivers while both cards were attached.  I have the same issue.

       

      If I just install the second card by itself, it doesn't disable the device, but won't allow the resolution above 800x600.

       

      Is the new card defective?  I think I can still return it, but with GPUs being so hard to come by right now, I'm not sure if NewEgg will have a replacement.

       

      Gigabyte Gaming 7 Z170X

      Intel 7700K

      2 x Radeon RX470 (4GB)

      512GB NVMe Samsung SSD

      16GB G.Skill Ripjaw RAM