2 Replies Latest reply on Oct 20, 2017 2:07 PM by aamir1

    Sapphire R9 270X Dual-X 4GB OC with Boost - Black Screen on Win7/10 Boot and Driver Install

    igles

      Dear friends,

       

      It's disheartening to start this thread, but I feel it's necessary, as a quick Google search will show you that thousands (yes) of people have the same issue as I do and the feeling that AMD and/or Microsoft don't give a don't is evident. All answers / methods / tricks to overcome this issue are widely available and have been tried. I am not looking for those. I'm almost certain the issue is at software level (either driver or OS compatibility).

       

      ISSUE: In ANY Windows OS version, the PC will not boot. After POST and Windows logo / white dots, it comes to a HARD FREEZE (no Caps/NumLock to confirm) where the screen is completely black (backlit), no mouse cursor.

       

      Booting using an adjacent graphics (not Crossfire) card will work and boot the PC to try and install drivers from within the system, but whenever ANY version of drivers from AMD, running from MOST RECENT to about 30 VERSIONS DOWN, will cause the screen to (normally) flicker but come to a complete hard freeze and backlit black screen. If the driver install is kept to take place after restart, problem reoccursat boot.

       

      SPECS:

       

      ASUS M5A97 LE R2.0 (no integrated graphics, latest BIOS)

      Sapphire R9 270X Dual-X 4GB OC with Boost (not UEFI-Ready, no UEFI Switch, latest BIOS)

      AMD FX 8320 @ 3,5GHz (no overclock)

      Corsair TX 650W 80 Plus Certified

      2 x 8GB Kingston HyperX @ 1600mhz

      Kingston HyperX USB Headphones

      Kingston SSD 980gb

      Cooler Master Case

      Simple Keyboard and Mouse

       

      WHAT HAS BEEN TESTED TO AVOID UNNECESSARY QUESTIONS:

       

      - Motherboard is new, fully functional, PCI-E x16 working properly, have tried 3 other cards.

      - GPU flashed to the most recent vBIOS provided directly by the Althon Micro Tech support.

      - PSU verified by two distinct professionals with multimeters.

      - MEMtest run several times, many loops, no errors found.

      - No thermal issues, PC is located in a room kept at 62,6F at all times.

      - All other components working fine.

       

      PROBLEM PROGRESSION:

       

      The card had been running FLAWLESSLY until about 6 days ago, when I finally gave in (unfortunately) and fresh installed (not an upgrade) Windows 10 version 1703 OS Build 15063.413. The problem started right there, where the BlackSOD happened at Windows Update. Understanding it could be a faulty driver from WU, I fresh installed once again

      and same BlackSOD happened as I was unable to prevent the driver installation, even though I set in Settings not to do it.

       

      At this time I removed the card and installed my trusty PSY GTX 760 in the system and went for a third fresh install, so I could update the system to the fullest. At this point I went to safe mode, uninstalled nVidia drivers and DDU and turned it off, and switched for the 270X. Same problem.

       

      I was able to retrieve the hardware ID for the 270X and set a local policy through gpedit.msc to prevent the drivers from auto-installing. At this point I tried WAY TOO MANY driver version from the AMD website, the original install from the CD that came with the GPU, all rendering the exact same results - black screen and hard hang.

       

      From this stage over, I proceeded to search for the solutions and it sort of freaked me out. Hundreds and hundreds of threads in this forum show the same issue and other several hundreds with no solution.

       

      I had only one way to go - back to Windows 7. What a f***ing disaster. Same issue.

       

      So after contacting Sapphire to help me out, then sending me to Althon Micro, flashing a UEFI-ready vBIOS, trying all sorts of manipulation with the atikmpag.sys files, DDUing back and forth, switching PCI-E slots, trying custom drivers, resetting and updating MOBO BIOS, different OS installs, I simply said "fine, the card is dead".

       

      But then it worked in two other righs of five that I tested.

       

      I REALLY don't know where to go from here. There MUST BE a solution out there, maybe the tiniest detail is what it's missing. Look here, here, and especially here for more descriptive cases.

       

      WHAT I HAVEN'T TESTED:

       

      - baking the card (temporary solution, I won't consider)

      - messing with voltages (don't really know how to do it)    

       

      ANY input will do.

       

      Igles.