2 Replies Latest reply on Jul 6, 2017 1:33 PM by hieuminhtorch

    Can't get AMD VCE to work.

    hieuminhtorch

      For a while now (over a year), I can't get AMD VCE to work with my screen recording software. My setup is an AMD 8350 at stock and an MSI R9 280X also at stock. I've tried plays.tv, OBS Studio, and AMD's own Radeon ReLive. Before all of the trouble happened, plays.tv recorded gameplay at 1080p 60fps at a 15mbs bitrate just fine. Then problems started to arise (huge frame rate drops in the recording) and afterwards I found out that plays.tv had switched to software encoding on the CPU judging by the near 99% CPU usage when playing games. I've tried reinstalling plays.tv, along with my other recording software that I've tried (multiple times), reinstalling AMD drivers (also multiple times), and ended up reinstalling windows itself to try to solve the problem. So far, no luck. I eventually narrowed the problem down to the recording softwares using software (CPU) encoding instead of hardware based encoding using my R9 280X.

       

      I've followed a forum on plays.tv to find out what plays.tv is actually using to encode on my computer:

      How to read your Hardware Level for Plays.tv : Plays.tv Support 

      TLDR: If I have a HW Level of 1, than AMD VCE is detected and working properly, but if I have a HW level of 4, than no hardware encoder can be found so software encoding is forced.

      Unsurprisingly, I have a HW Level 4.

       

      OBS Studio's Auto configuration utility that tries to configure the settings automatically based on the user's hardware chose these settings (picture attached):

      So along with plays.tv, OBS also chooses software encoding and there is no option in the settings to change to any other encoder.

       

      I must also mention that due to problems with the latest drivers, I've rolled back to Radeon Software Version 16.6, but the problems still persist with the latest drivers as off the time of this post.

       

      So, help?

        • Re: Can't get AMD VCE to work.
          ray_m

          We cannot really comment on why Plays.TV does not work.

           

          Have you tried AMD Relive ? If so, what happens there?

            • Re: Can't get AMD VCE to work.
              hieuminhtorch

              Thanks for responding!

               

              I've uninstalled my current driver (Radeon Software Version 16.6), and installed version 17.4.4.

              I tried to use AMD Relive to record some CS:GO gameplay but when I go to check the folder where the recordings are saved, the files seem to be corrupted since they don't show anything when opened with VLC. There is also no notice that tells me that a recording is started when I do the recording hotkey.

              I recorded another game called simple planes, and when I do the record hotkey, there is a little prompt that tells me to enable desktop recording. When I enabled that, ReLive only records my cursor and whatever was in the background at the time the recording hotkey was executed. So the only thing was just a screenshoted screen of me in game and a cursor moving around.

               

              EDIT:

              It's been the day after this post where I decided to try to record some League of Legends gameplay. The recording actually worked but the end result was an incredibly choppy video. (1-5 fps).