1 Reply Latest reply on Jun 30, 2017 11:23 PM by nimono

    Suddenly receiving a "No suitable graphics card found" error when trying to run XNA games

    nimono

      I am receiving a mysterious error when trying to play XNA games. They will immediately quit saying "No suitable graphics card found. Could not find a Direct3D device that supports the XNA Framework Reach profile." It only started up this week, after I received a SADES SA708-GT headset, plugged it in, then had to update my VIA HD Audio sound drivers to get the microphone on it to be recognized. The games were working just fine the week before. There's no dedicated sound card, it's integrated. I am on Windows 10, my processor is AMD FX-8320, and my graphics card is a Radeon R7 200 series. I only just noticed the problem yesterday, and today took steps to try to fix it, including uninstalling and reinstalling the games, doing the same to XNA 4.0, checking the permissions on XNA 4.0, updating DirectX drivers, and updating my AMD drivers to the latest driver for today. Nothing fixed the issue, so I am at a loss, especially given most of my available PC games appear to use XNA. The only step I haven't been able to check is hardware acceleration, but I have been unable to find that option anywhere, not even in the Radeon control panel. I checked dxdiag, every feature says it's enabled, so it's definitely not that, although dxdiag always crashes if it's allowed to use DirectShow for some reason.

        • Re: Suddenly receiving a "No suitable graphics card found" error when trying to run XNA games
          nimono

          I'd like to add something to this. I did more research on the DirectX issue, and found a potential solution I hadn't tried before, and figured "why not?" When I tried it, it actually WORKED, completely refreshing DirectX and letting everything run properly! The solution was: Device Manager > Uninstall the graphics card & drivers > Restart computer. Taking these steps was able to completely fix my issue, somehow. I felt like I should post this solution here, in case others run into this issue in the future. It may not work for everyone, but it worked for me. I do wonder, though- why DID it work for me? What exactly did this do?