AnsweredAssumed Answered

Can't update driver to the correct version. HD 4600 Series Catalyst 13.9

Question asked by esteigs on Jun 25, 2017
Latest reply on Jun 27, 2017 by esteigs

Sorry guys, I'm not super tech savvy so you're gonna have to explain it in pretty simple terms to me. But what happened is I got a new game, and when I launched it I got this message:   "The installed version of the AMD graphics driver has known issues. Please update to the latest driver version.   

ATI Radeon HD 4600 Series

Installed: Catalyst 13.9

Recommended: 16.300.2311.0

 

I tried to use the automatic updater system that the AMD site provides, but it only installed me with the catalyst version. Any help would be great!

 

Message was edited by: Matt B We have updated the title of this discussion with relevant details to better describe your issue.

Outcomes