2 Replies Latest reply on Jun 26, 2017 10:22 AM by rebelyell

    Black screen after installing drivers for Radeon HD7850 following Windows 10 Creators Update

    popocatepetl

      I own a Sapphire Radeon HD7850 (2 GB DDR5) which has served me well until recently. In early May, following the installtion of the Windows 10 Creators Update, I experienced a problem with the screen turning black after booting. As I could not fix the problem, I did a fresh installation of Windows 10 (Version 1703, Creators Update), but experienced the same problem. After experimenting a bit, I figured out that the problem pops up once the AMD drivers are installed. While I am using the generic Microsoft video graphics drivers - either in safe mode or by removing the AMD drivers - everything works fine (graphics performance aside). Following recommendations in mutliple forums, I installed different versions of the AMD Crimson drivers downloaded directly from the AMD website (versions 15.12, 16.7.3, 16.9.2, 17.5.2), but also tried installation via Windows Update, all leading to the exact same problem. Below is the system specification I am using. I would very much appreciate any hints that may help fixing the issue as I have simlpy no further ideas what to try. As mentioned, until April everything was working fine under Windows 10 (update from a previous Windows 7 installation), but maybe the issue I am experiencing just coincided with the Creators Update...

       

      • Windows 10, 64 Bit, Version 1703, Build 15063.413
      • Shuttle XPC SZ77R5 with Intel Z77 chipset, BIOS rev 113 (latest available, dated November 2014)
      • Intel Core i5-3450s
      • 16 GB DDR3 RAM
      • Sapphire Radeon HD7850 (2 GB DDR5)
      • Samsung 850 EVO SSD, 500 GB