AnsweredAssumed Answered

Cannot Load Detection Drivers - RX 480

Question asked by shuumi on Jun 17, 2017
Latest reply on Jun 17, 2017 by goodplay

Hello,

today i wanted to update my drivers. I downloaded new ones, sadly, they didn't turn on. Windows threw the standard "AMD Software doesn't work" and it closed.

I tried debugging, which showed a ton of exceptions thrown, some of them about dlls, like d3d9.dll.

I thought then, maybe one of my programms breaks the installer. I rebooted to the safe mode and tried to start the instalation.

It went one step further: The AMD Software threw an exception you can see below. It says something about "cannot load detection drivers". Probably the lack of internet connection stops it.

I also tried uninstalling my old driver with Driver Cleaner and installed an old 15.11 driver (which does not support my card) and cleaning via the app included to the driver. Sadly i can not go any step further.

 

Now i sit with my almost greyscale screen, unable to work because my 2nd display doesn't turn on.

 

My Specs:

Processor: Intel Core i7-7700K 4.2 GHz

Videocard: RX 480 8GB

RAM: 16GB

Motherboard: Asus Z170-A

OS: Windows 10 Pro 64Bit

 

Message was edited by: Matt B We have updated the title of this discussion with relevant details to better describe your issue.

Attachments

Outcomes