13 Replies Latest reply on Aug 8, 2017 8:31 AM by alainbrest

    RX 550 4G DDR5 linux debian 9 drivers

    alainbrest

      i found amdgpu  linux driver

       

      do you confirm it is debian 9 (stretch) compatible ?

       

      thanks

       

      on windows 10 home  , card works perfectly with rc4 (17.6.1) driver

      cpu load , in full screen video (2560 x 1600) , is +/- 3% and the image is quite perfect .

       

      on debian 9 (stretch),

      often , there are blinkings with black screens .

      so , i wonder : where does the problem comes from ?

      amdgpu seems not to install polaris 12 but only 10 & 11 versions .

       

      i don't know what to do .

       

      and  i need help

       

      do someone can help me ?

       

      Message was edited by: alain bellec

        • Re: RX 550 4G DDR5 linux debian 9 drivers
          alainbrest

          ok , thanks .

           

          perhaps , yes , it will be great.

            • Re: RX 550 4G DDR5 linux debian 9 drivers
              jpg

              I was able to install the driver (see bellow for details on how I did it). My problem though is that clinfo does show a platform with name "AMD Accelerated Parallel Processing" but with only 1 device with type CL_DEVICE_TYPE_CPU. So the GPU does not appear as an available device.

               

              Install steps:

               

              First download the following deb file "libssl1.0.0_1.0.1t-1+deb8u6_amd64.deb" from Debian's repositories.

               

              Install it by running: dpkg -i libssl1.0.0_1.0.1t-1+deb8u6_amd64.deb

               

              Now, one of the problems in the installer is the one explained here: https://community.amd.com/thread/214763. To solve it you first extract the amdgpu-pro-dkms_17.10-450821_all.deb.

               

              dpkg-deb -R amdgpu-pro-dkms_17.10-450821_all.deb ./amdgpu-pro-dkms

               

              Then edit a main.c file in there:

               

              vi ./amdgpu-pro-dkms/usr/src/amdgpu-pro-17.10-450821/amd/amdkcl/main.c

               

              Add "//" in front of the lines 8 and 15 to comment them out

              ...

              //extern void amdkcl_io_init(void);

              ...

              //amdkcl_io_init();

              ...

               

              Then calculate the md5sum of the changed file.

               

              md5sum ./amdgpu-pro-dkms/usr/src/amdgpu-pro-17.10-450821/amd/amdkcl/main.c

               

              Edit the file ./amdgpu-pro-dkms/DEBIAN/md5sums. This file is a list with md5sum and the filename. Find the file line "4abf01203c31cb0586fd4160e88d597c  usr/src/amdgpu-pro-17.10-450821/amd/amdkcl/main.c" and replace the old "4abf01203c31cb0586fd4160e88d597c" value with whatever was the md5sum you calculated for the changed value.

               

              Rebuild the deb file.

               

              dpkg-deb -b ./amdgpu-pro-dkms amdgpu-pro-dkms_17.10-450821_all.deb.mod

               

              Next is to edit the install script.

               

              vi amdgpu-pro-install

               

              Go to line 49 and change "ubuntu" to "debian".

              I also had to remove from line 50 the "amdgpu-pro-lib32". I did that because I didn't need the 32-bit version and it was causing some issues during installation.

               

              Now we run the install script. "./amdgpu-pro-install"

               

              Wait for the installation to finish.

               

              Then install the moded deb. "dpkg -i amdgpu-pro-dkms amdgpu-pro-dkms_17.10-450821_all.deb.mod"

               

              Reboot and you will be at the same situation as I am. :-)

                • Re: RX 550 4G DDR5 linux debian 9 drivers
                  jpg

                  So does anyone know why clinfo only shows the CPU in the available devices and not the GPU? Am I missing something?

                    • Re: RX 550 4G DDR5 linux debian 9 drivers
                      alainbrest

                      it seems that i had nearly the same problem as yours .

                      once , i managed to run a tinkered amdgpu and it seems it was working well but , in fact , no , only the cpu was  working , not the gpu .

                      i am still waiting amd's firmware for debian and i know (because of few researchs) that this card works well :

                       

                      1) on ubuntu 17.04 at least

                      2) on arch linux (the latest)

                      3) on windows 10 / 7

                      4) on debian 9 (stretch) with at least 4.11 kernel , amd's firmware (Unavailable at the moment) and the latest amdgpu .

                       

                      good luck and don't forget to reply .

                      thanks

                      • Re: RX 550 4G DDR5 linux debian 9 drivers
                        flos

                        I have this issue also with Ubuntu 16.04.2, after installing the drivers on a APU + RX550 system clinfo only shows the APU/CPU device not the RX550

                          • Re: RX 550 4G DDR5 linux debian 9 drivers
                            alainbrest

                            i want to tell you :

                            this card is not operable on jessie . (debian 8)

                            when using debian 9 (stretch) for this card  , you need :

                             

                            1) at least , KERNEL 4.11 (kernel.org)

                            2) AMD 'S FIRMWARE (not available at the moment)

                            3) AMDGPU

                            4) at least , MESA 17 (not available at the moment , still in developpement in debian)

                             

                            on UBUNTU , this card works with , AT LEAST , ZESTY VERSION (17.04)

                            on ubuntu 16.04.2 , drivers are not  ready and kernel , too . it is 4.8 or 4.9 instead of 4.10 on zesty

                            of course , more recent is the kernel , better it is . because of compatibilities .

                             

                            here is my glxinfo -B on ubuntu 17.04

                            alain@alain-System-Product-Name:~$ glxinfo -B

                            name of display: :0

                            display: :0  screen: 0

                            direct rendering: Yes

                            Extended renderer info (GLX_MESA_query_renderer):

                                Vendor: X.Org (0x1002)

                                Device: AMD POLARIS12 (DRM 3.9.0 / 4.10.0-26-generic, LLVM 4.0.0) (0x699f)

                                Version: 17.0.3

                                Accelerated: yes

                                Video memory: 4065MB

                                Unified memory: no

                                Preferred profile: core (0x1)

                                Max core profile version: 4.5

                                Max compat profile version: 3.0

                                Max GLES1 profile version: 1.1

                                Max GLES[23] profile version: 3.1

                            OpenGL vendor string: X.Org

                            OpenGL renderer string: Gallium 0.4 on AMD POLARIS12 (DRM 3.9.0 / 4.10.0-26-generic, LLVM 4.0.0)

                            OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.0.3

                            OpenGL core profile shading language version string: 4.50

                            OpenGL core profile context flags: (none)

                            OpenGL core profile profile mask: core profile

                            OpenGL version string: 3.0 Mesa 17.0.3

                            OpenGL shading language version string: 1.30

                            OpenGL context flags: (none)

                            OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.0.3

                            OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

                            where you can see my card perfectly recognised (Device line) , the version of the drm and the kernel (4.10.0-26) and , the line under , the mesa version .

                              • Re: RX 550 4G DDR5 linux debian 9 drivers
                                jpg

                                Hi,

                                 

                                I have tried on an arch linux with 4.11.9 kernel (the default one). I have installed the opencl-amd AUR, which uses the AMD driver. The "AMD Accelerated Parallel Processing" platform still shows only the CPU as available device. The "lspci -k" does show that the device is using the amdgpu driver.

                                 

                                If I install the mesa 17.1.4, there is a "Clover" platform in clinfo which has one device which is the GPU. But the mesa opencl version is only 1.1 there.

                                So I am still not sure what is the issue. Where and how could I get debug info for this?

                                  • Re: RX 550 4G DDR5 linux debian 9 drivers
                                    alainbrest

                                    hi! , jpg .

                                    i don't know very well arch .

                                    one of my friends managed to use this card on arch linux but me , i didn't .

                                    thus i've tried nearly 6 distributions of arch .

                                    the recommended one (arch anywhere) seems to work well but it has problems with de card's  drivers ,

                                    and , in fact , it  doesn't works at all .

                                    the O.S. i managed to run perfectly with this card are :

                                     

                                    windows 10 familly

                                    ubuntu 17.04

                                     

                                    for more information , see the amd's downloads site

                                    you will see the O.S. the amd's card supports .

                                     

                                    about debian , nothing is ready yet  : no more mesa than the firmware etc ...

                                     

                                    note : i don't know  what is "clinfo" . i prefer "glxinfo" , or , better , "Xorg.log"