2 Replies Latest reply on Jun 11, 2017 1:33 AM by nospheratu

    R9 290X - Unable To Restore 17.5.2 After Updating to 17.6.1

    antediluvian_despot502

      Hello all, i'm new here (but I DID try searching the forum for information on this before posting)

       

      So, card:

       

      AMD RADEON R9 290x 4gb vram

       

      So, Crimson alerts me to new OPTIONAL 17.6.1 update. Was running previous full update to that originally (17.5.2)

       

      So I try installing 17.6.1, says UNABLE TO INSTALL, UNSUPPORTED GRAPHICS HARDWARE (this happened to be once before with another OPTIONAL driver update. All I did was rollback and wait for it to come out of beta, so the normal version worked fine) so fine. So I used AMD's recommended (from the driver page itself) video driver uninstaller.

       

      Did that. Tried running the 17.5.2 install package. Package unzips but doesn't auto-run Setup.

       

      Go to 17.5.2 folder in C:\amd and hit setup. Setup tells me it's updating and then it lets me install.

       

      So install works fine, restart, check Radeon Settings proggie for driver version and i'm stuck on 17.4.4! After purely running the 17.5.2 package only!

       

      Radeon will only give me the option to update to 17.6.1 (which I obviously don't want to do right now).

       

      I've tried removing the drivers with the program over and over again, but keep getting stuck at this point.

       

      Any thoughts? Getting very frustrated..

       

      Message was edited by: Matt B We have updated the title of this discussion with relevant details to better describe your issue.