AnsweredAssumed Answered

Crimson 17.6.1 Installation not working on RX480 Win7 x64

Question asked by etayorius on Jun 8, 2017
Latest reply on Jun 13, 2017 by johnniedoo

This a fresh Win7 x64 install with all the latest updates, i tried the new 17.6.1 drivers but it does not seem to install the driver nor the Settings. Installation completes very fast and is not even asking for a reboot. I tried downloading the file which is 456MB 4 times in a row and the result is the same. I even tried with previous 17.5.2 and is seems to be working perfectly, but 17.6.1 simply is not.

 

Fresh Win7 x64 with all updates.

8GB RX-480M8BFA6 (With Stock 1288MHz)

Intel Core i5 6500
8GB DDR4 2133MHZ

Asus H110M-A

Speler Full HDTV 21" through HDMI1

 

 

While selecting Custom Install the only available option is HDMI Audio Device. I believe that the Package itself might have some sort of issue.

 

 

Edit 1

 

Installing 17.5.2 then forcing the W76A_Inf through device manager sort of works, but it is not ideal... there is definitely something wrong in the current package file for Win7 x64 version.

 

Edit 2

 

I tried 17.6.1 on a old PhenomII PC with also "Win7 x64 and the result is the same. What the heck is wrong with this new driver? why can't i install them on two different PC's?

 

Edit 3

 

I am just going to stick to 17.5.2 for a month or two, this new Driver Package is not working in any of my systems no matter what i do, i will also attach a DxDiag and MSinfo just in case any Engineer or Developer want to take a look.

Attachments

Outcomes