AnsweredAssumed Answered

clock fluctuations with rx580

Question asked by telco on Jun 3, 2017
Latest reply on Jun 4, 2017 by xeleron


I have a new AMD RX card and in one game in particular, (Planetside2), I get a lot of screen stutters in that game that is really noticeable and extremely irritating.  I am pretty sure that the issue is related to the clock rate fluctuating so much.   It ranges from about 400mhz to about 1100mhz, never really reaching the max clock rate.  When it is pretty high, I don't really notice the stutter, but it doesn't stay at the higher clock rate for very long.

Granted PS2 is not a GPU intense game, but I want a way to be able to keep the gpu from fluctuating this much when I'm playing it.  I haven't found a way to do that yet.   Others have seen a lot of improvement with disabling power efficiency, (noted in earlier versions of the Crimson drivers) but that option is not available to me under global, or the game specific profile.


Is there a way to disable it, should it be default enabled?  I really just need the PS2 profile modified when playing that game to address the issue.  Other games I haven't had this large of a problem, but the card is new and I haven't played many games on it yet.

Graphic settings in the game don't seem to make much of a difference.  (seems that when they are lowered, the problem is worse, but that's hard to quantify)


  • AMD Graphics Card
    • ASUS Strix AMD RX 580 O8G
  • Desktop or Laptop System
    • Desktop
  • Operating System
    • Windows 10 64bit
  • Driver version installed
    • Radeon Software Crimson Edition 17.5.1
  • Display Devices
    • DVI Main - ASUS VE278Q  @60hz 1920x1080   (have something else in hdmi port)
    • HDMI Second monitor - Samsung Syncmaster XL2370  @60hz  1920x1080
  • Motherboard
    • Gigabyte GA-990FXA-UD3  (AM3+)
    • AMD FX 8370
  • Power Supply Unit  Make, Model & Wattage
    • 800W Gold
  • RAM
    • 12GB