rsmostowy

Black Screen When Loading Games - RX 480 x2 17.5.2

Discussion created by rsmostowy on Jun 3, 2017
Latest reply on Jun 13, 2017 by amdmatt

AMD Graphics Cards - RX 480 8GB x2

OS - Windows 10 64bit

Driver version - Relive 17.5.2

Monitor - Acer GN276HL 1920x1080 @ 144hz DVI

Motherboard - ASUS PRIME B350-PLUS

CPU - RYZEN 7 1700X 8-Core 3.6GHz

PSU - Sentey MBP750-HM Power Supply, 750 watts

RAM - CORSAIR Vengeance LPX 16GB (2 x 8GB) 288-Pin DDR4 3000

 

 

My drivers crash (with no error message, just a black screen) every time I load up a game. Doesn't matter what game I try to play(Overwatch, WoW, H1Z1, CSGO and a few others). Chrome even crashed them via YouTube. I upgraded my computer recently. I bought a new motherboard, CPU and RAM. I had the 2 RX 480s already and they we're working fine with my old setup. I received and put together my new hardware and reinstalled windows/updates/BIOS and this problem arose. I've got Windows installed on a Samsung 850 EVO 2.5" 250GB SSD, and everything else on a WD Blue 1TB. I've tried with just a single GPU and have the same problem. Everything except for the WD HDD is brand new, but I had no problems with it prior to relocating and reformatting.

 

 

I think my HDD might be going bad, but I wanted to get an experts opinion. I have reinstalled, reformatted, removed, re-seated everything. I also replaced the SATA cables. I at a loss here.

 

Message was edited by: Matt B We have updated the title of this discussion with relevant details to better describe your issue.

Outcomes