14 Replies Latest reply on Jun 16, 2017 7:13 AM by shika93

    Switchable Graphics Not Working Since Windows 10 Upgrade Intel HD3000/AMD HD 5470M

    shika93

      I've got a problem with my laptop HP G62-a16SL with Windows 7 x64. Playing with flash/java games, like the ones on Facebook, I've got the CPU load very high (80-100%) like it doesn't work the hardware acceleration.

      This pc has a ATI Mobility Radeon HD 5470, so I tried uninstalling its driver using this tool

      AMD Clean Uninstall Utility

      and reinstalling the driver

      http://support.amd.com/it-it/download/desktop/legacy?product=legacy3&os=Windows%207%20-%2064

      After the installation is completed, I reboot and when I go in the switchable card's page of the Catalyst, there aren't the buttons to switch GPU from the Intel one to ATI. Then I try to disable the Intel's GPU from the Control Panel to force my pc to use the other GPU but it looks like the drivers are missing. It changes the resolution and when I reboot appears the message "Driver missing or not working". I don't know what to do.

      I've also tried using the autodetecting tool  in case I was installing wrong drivers but still doesn't work.

      In any case, the GPU is detected because I can seen it from the Contro Panel.

       

      And yes, I already tried to reinstall the original drivers using the Recovery Tool.

       

      Message was edited by: Matt B We have updated the title of this discussion with relevant details to better describe your issue.