31 Replies Latest reply on Jun 5, 2017 2:10 PM by ray_m

    Default Radeon WattMan settings have been restored - RX 480 - Affecting Crimson 16.7.3 Onwards

    andreluisos

      Specs:

       

      • ROG RX 480 STRIX 8GB
      • Desktop
      • Windows 10 CU 64bit
      • Latest driver available from AMD website.
      • Display 1: Dell S2340L / Display 2: LG TV 47". Both through HDMI
      • GA H97MGAMING-3
      • Intel i5 4690k
      • EVGA GQ 650W 80+GOLD
      • 16GB (2X8GB) DDR3 133MHZ CORSAIR VENGEANCE

       

      The issue:

       

      https://youtu.be/XwZWzFOxA7I

       

      As you can see on the video, on every minute of the game, the screen freezes, goes completely back (sometimes I can see on the display Power Saving Mode) and then it comes back, followed by "Default Radeon WattMan settings have been restored due to unexpected system failure" error. Card is running on the out of box clocks.

       

      Lineage 2 is a very old MMORPG, just like WOW. It's very common to open more than one instance of the game, which works perfectly on NVIDIA cards. The game runs in windowed mode and uses DX 9.0c.

       

      This is my first Radeon card (actually the second one, cause I RMA the previous one).

       

      List of things I've tried (all these tweaks were already tested, and it doesn't fix the issue. Not to mention that the driver should work out of the box. You shouldn't do any tweak to make a driver work properly. If it's not working out of the box, it has bugs and it must be fixed):

       

      - Clean install of Windows 10 (no nvidia cards installed).

      - Before installing any driver, I used DDU to remove AMD driver and iGPU driver (which was disabled on BIOS to avoid incompatibility, or w/e radeon snowflake needs). Also I've used Hidding AMD driver from windows update using "Windows Update Show Hide troubleshooter". No driver was installed before these steps.

      - I've tried all drivers since 16.11.5;

      - I've tried Windows Update drivers;

      - I've tried installing drivers only (without AMD Settings);

      - Tried GPUTweak II instead of AMD settings;

      - Tried downclocking GPU;

      - Tried new CPU and RAM;

      - Triend another motherboard (older one, but its still another mobo)

      - Bought a new PSU (650W 80+ Gold);

      - Limiting FPS to 15;

      - Disabled Game DVR;

      - Taking pills don't die frustrated.

       

      After months of testings I got the following conclusions:

      1- it doesn't happen with NVIDIA drivers (even when you're running on a very old card, like GTS 450);

      2- it only happens if the game is running in the foreground. If you're doing another task while the game still runs in the background, it wont crash. It also proves that its not hardware fault, since it'd crash anyways.

      3- only the drivers 16.7.3 and above are crashing; 16.7.2 and below aren't.

      4- for all of that, IT IS A DRIVER ISSUE.

       

      List of drivers I've tested (I will update this list):

       

      16.5: not crashing. > this one is the older one available at the ASUS' website (suggested for ROG RX 480 STRIX 8GB ONLY)

      16.7.1 (with or without compatibility mode): not crashing. > Detail

           - no Wattman restoring it's default settings nor game black screens. But the same cosmetic crashes on Wattman happens the same way as 16.7.2.

      16.7.2 (WHQL - with or without compatibility mode): not crashing. > Detail

           - been using 16.7.2 for a while now. The screen doesn't go black at all, making it completely playable. However, a few cosmetic Wattman crashes happens when you try to access Wattman' settings sometimes. If you are using a game profile, it will stop using it and go back to the Global Wattman settings, though.

      16.7.3 (WHQL): entered power save mode and didn't want to get back. Had to restart the computer. "Default Radeon WattMan settings have been restored due to unexpected system failure" came on the boot.

      16.10.1 (WHQL): crashing.

      16.11.2: crashing.

      16.11.5 and above: crashing.

       

      As suggested by @kingfish bellow, I submited a support ticket to AMD and they did send me an email asking details of the issue, which was promptedly sent. If you are having the same issue, please try one of those green drivers listed above and see if your issues are gone. If they are, PLEASE DON'T HESITATE CONTACTING THEM AND LETTING THEM KNOW OLDER DRIVERS ARE WORKING AND NEWER ONES ARE CRASHING. This is the only way to get this bug patched on the upcoming updates.

       

      AMD Issue Reporting Form

      Email Form

       

      Message was edited by: Matt B We have updated the title of this discussion with relevant details to better describe your issue.