13 Replies Latest reply on Jun 10, 2017 2:56 AM by amdmatt

    R9 290 Crimson 17.3.3 - 17.5.2 Unable To Launch Game

    wiwigvn

      After Windows 10 Creator, I cannot launch any game, new or old, with my R9 280.

      I tried uninstalling (using DDU) and installing drivers several times, including the 17.3.3 version and 17.5.2 version (latest version for my card).

      Has anyone encountered this problem and found solution?

      Thank you very much!

       

      Message was edited by: Matt B We have updated the title of this discussion with relevant details to better describe your issue.

       

      Edit: I will try to be clearer about this issue:

       

      At first, when Windows 10 Creator version had just been updated, when I tried to launch a game, an error message would appear and automatically closed my game. It was different for each game. I can only recall that for Mount&Blade, the error was "Could not find compatible Direct3D devices".

       

      Then, I tried installing the latest drivers from AMD, all of the troubled game would simply crash with the standard message "xxx has stopped working. Windows is checking for a solution to the problem..."

       

      I tried some tweaks and installation but the issue persists. But I found out that not all games encounter this issue, some work, like Age of Empires II HD Edition.

       

      Message was edited by: Nghia Cao clearer about this issue: