10 Replies Latest reply on Jun 15, 2017 4:35 AM by pico118

    RX 480 BSOD and Driver Crash

    mrclean

      I just got a 480 about a month ago and never had any problems until recently. Suddenly after a few minutes of playing a game or running heaven benchmark the screen starts going gray and then the card either crashes or I get a BSOD that says THREAD_STUCK_IN_DEVICE_DRIVER. It all started when I updated to 17.5.2. So I rolled back the driver to 17.4.4 and I still get the problem. So I tried 17.3.3 and then 16.11.3. Keeps happening. Is my card just completely bricked now?

       

      -- System --

      OS: Windows 10 Home 64-bit

      CPU: AMD Ryzen 5 1600X @ 3.9 GHz

      MOBO: Gigabyte AB350 Gaming 3

      VIDEO: PowerColor RedDevil RX 480 8 GB

      MEM: 16GB G.Skill FlareX @ 3200 MHz

      PSU: EVGA SuperNova 750 G2

       

      I've seen this is a common problem, one of the solutions was to flash the bios to stock settings and I have no idea how to do that and it seems risky. I really don't want to return the card, but i guess I will if I have to.

        • Re: RX 480 BSOD and Driver Crash
          pico118

          I got the same Problem but with a bit different setup.

           

          -- System --

          OS: Windows 10 Pro 64-bit

          CPU: INtel i7-7700K

          MOBO: MSI Z270 PC Mate

          VIDEO: PowerColor RedDevil RX 480 8 GB

          MEM: 16GB DDR4 3200 CL16 CORSAIR KIT

          PSU: Nitrox 750W

           

          Nearly every games crashed after some minutes. CPU Temperature looks still good ( 48" ) and i switched the PSU and the error still there.

          • Re: RX 480 BSOD and Driver Crash
            mrclean

            So I went ahead and did a clean reinstall of Windows 10 and updated it. Then I installed the Crimson ReLive Edition 17.4.4 driver to see if I could go back to the stability I had before. No luck. Then I installed the Crimson Edition 16.11.5 Hotfix HERE and it's a little better. The screen still occasionally flickers gray and hangs for a second like its going to crash, but no crash yet *crosses fingers*.

             

            It looks like I'm stuck with this 6 month old driver because I kinda don't know what else to do. I might try undervolting the card since somebody said that might work but I guess that would require me to reinstall the newer driver to get Wattman. Idk.

             

            If anybody has had this problem and solved it, please let me know.