14 Replies Latest reply on Jan 31, 2018 11:17 AM by msscha01

    System has detected a link failure and cannot set the requested resolution - Samsung CFG70 with RX 580

    sleepygeepy

      Hello Everyone,

       

      First time posting here, so forgive me if this issue has been resolved already.  I recently bought a Samsung CFG70 monitor (27-inch version) and I have been pairing it with a Sapphire RX 580 NITRO+ graphics card.  I'm using the DisplayPort cable that came included with the monitor, which seems like a high quality cable.  I have been encountering the following issue whenever I enable FreeSync on the monitor's OSD menu and set the monitor as FreeSync capable in the Display Tab of AMD Radeon Settings.

       

      "The system has detected a link failure and cannot set the requested resolution and refresh rate on your DisplayPort display. Your display might not support the requested resolution or there may be an issue with the cable connecting the display to your computer..."

       

      Then I noticed in the display adapter properties in Windows I can only set the refresh rate to 60Hz and the monitor properties can only go up to 60Hz.  This happens whenever I'm on the Windows desktop or playing a game in full screen mode.  As soon as I enable FreeSync on the monitor's OSD menu, the DisplayPort link failure occurs and the monitor runs at 60Hz refresh rate.

       

      Before I go any further, here are the details of my system:

       

      Hardware

      Processor: AMD Ryzen 1600X

      Motherboard: ASRock X370 Taichi

      Memory: G.Skill Flare X DDR4-2400 2x8GB Kit

      Storage: Crucial MX300 275GB SATA SSD + Seagate Barracuda 2TB HDD

      Graphics: Sapphire RX 580 NITRO+ 8GB (regular version)

      Power Supply: Seasonic G-650

      Case: Fractal Design Define C

      Cooling:  Noctua NH-D15 SE-AM4 (CPU cooler) + 4x Cougar Vortex HDB case fans

       

      Software

      Operating System: Windows 10 Professional 64-Bit

      AMD Chipset Driver: Version 17.10 RCP22 (April 27, 2017)

      AMD Graphics Driver: Radeon Software Crimson ReLive version 17.4.4 WHQL (May 4, 2017)

      Monitor Driver: Samsung C27FG70 Driver version 1.0

       

      When I try using the included HDMI cable on the monitor, I'm able to turn-on FreeSync on the OSD menu and the monitor gets detected as FreeSync capable by the graphics card.  The refresh rate of the monitor also runs at 120Hz (which is specified for HDMI) and I'm able to play games with FreeSync enabled at that refresh rate.  As long as I use the HDMI connection everything seems to be working fine, but once I use DisplayPort the link failure issue occurs and the monitor runs at 60Hz if I turn on FreeSync on the monitor.

       

      Some things I have tried and quirks I noticed while using the DisplayPort connection:

       

      • Moving the cable to the other DisplayPort outputs on the videocard does not seem to have any effect.
      • I tried doing a fresh install of Windows and only installing the latest chipset drivers and graphics drivers from the start.  Still encounter the same issue.
      • Turning off FreeSync on the monitor allows the monitor to run at 144Hz and the display adapter properties / monitor properties in Windows allows me to choose the 144Hz setting.
      • I tried using the FreeSync "Standard Engine" and "Ultimate Engine" settings in the monitor's OSD menu.  Choosing either setting will make the monitor default to 60Hz and cause the link issue.
      • I also tried setting the Response Time to "Standard", "Faster", or "Fastest" in the OSD menu with FreeSync off. Once you turn-on FreeSync, the link issue occurs and monitor runs at 60Hz.
      • I also tried setting the Low Input Lag to "On" or "Off" in the OSD menu with FreeSync off.  Once you turn-on FreeSync, the link issue occurs and monitor runs at 60Hz.

       

      This seems to be a driver issue, because another post here: 480x link failure error message  describes the same issue I'm getting.  I haven't tried using older chipset or graphics card drivers as I don't know where to download them, and I feel more comfortable using newer drivers on the graphics card.

       

      I could settle with HDMI for now and enjoy 120Hz refresh rate + FreeSync, but when using HDMI the colors do not look right and image on the monitor looks a bit soft.  I think this might be a scaling issue or color issue when using the HDMI outputs of the RX 580 but I'm not sure.  So I'm sticking with the DisplayPort connection for now and not running FreeSync.

       

      Any thoughts, suggestions, or solutions to this issue is greatly appreciated.  Thanks

       

      Message was edited by: sleepygeepy = Added the link to the post with the related issue