AnsweredAssumed Answered

Is my GPU dead?  Started with black screen, now drivers won't install.

Question asked by hoogs on May 27, 2017
Latest reply on May 31, 2017 by hoogs

OS:  Windows 10 64bit, Desktop

GPU:  XFX - Radeon HD 7950 3GB, purchased in October of 2013

Monitor:  Acer - G246HLAbd 24.0" 1920x1080 60Hz (DVI)

Motherboard:  ASRock - Z77 Pro4 ATX LGA1155

CPU:  Intel - Core i5-3570K 3.4GHz Quad-Core Processor

PSU:  Cooler Master - Silent Pro M2 620W 80+ Bronze Certified Semi-Modular ATX

RAM:  Crucial - Ballistix Sport 8GB (1 x 8GB) DDR3-1600 Memory

 

Issue started one day when my PC booted to a black screen.  Went into safe mode > Device Manager > Display adapters and disabled my GPU.  This allowed it to boot normally so I uninstalled/reinstalled GPU drivers to no avail.  I can't remember the exact order I did things in, but at some point I:

 

  • did a clean reinstall of Windows
  • disconnected my GPU and cleaned connections with a soft pencil eraser as recommended online somewhere
  • attached a second monitor to my motherboard with my main monitor attached to the GPU (screen remains black) while attempting to install various driver packages (mainly these)
  • disabled Driver Signature Enforcement
  • ran AMD Clean Uninstall Utility and Display Driver Uninstaller before reinstalling drivers

 

I have gotten Error 99, Error 173, and Error 175 while attempting to install drivers.  My GPU is firmly connected to my motherboard including both power cables, and the fans are spinning.  I'm now at a loss.  Any help is hugely appreciated as I very much hope to avoid needing to buy a new GPU.  Thank you.  DxDiag Report attached.

Attachments

Outcomes