3 Replies Latest reply on May 30, 2017 6:21 AM by brook

    Starcraft: Brood War Colour Corruption

    brook

      Hi everyone,

       

      When I play SC:BW 1.18 (every version they've released I have this bug), I occasionally get a bug which causes the colours on my screen to go all wonky and it makes the game unplayable . I've attached some pictures. I can't reproduce when it occurs as it seems to occur apparently at random.

       

      Clean install Win10 and SC

      Card:

      ASUS RX460 (stock, never been overclocked or unlocked)

      Type:

      Desktop

      OS:

      Win10 64 bit

      Driver:

      Radeon Software 17.5.2

      Display device:

      (Main) Kogan 24" LED 144Hz Gaming Freesync Monitor @  144Hz DVI-DVI,

      (Secondary) AcerH243HX HDMI-HDMI

      Motherboard:

      GA-X58A-UD7 (rev 1.0)

      CPU:

      Antec 750W

      RAM:

      6GB

       

      If anyone has any suggestions please let me know. Thanks

        • Re: Starcraft: Brood War Colour Corruption
          ray_m

          This game is almost 20 years old and may experience issue with current graphics cards and drivers.

           

          You should use the last driver that worked with this game.

          1 of 1 people found this helpful
            • Re: Starcraft: Brood War Colour Corruption
              brook

              Hi ray_m,

               

              Thanks, I really appreciate the response.

               

              1.18 is a new patch released only a month ago by Blizzard in preparation for their remastered version. It has been, supposedly, modernised to work on new systems, so I'm not sure this is the case.

               

              I've attached further pictures available at this link here: http://imgur.com/a/b9eqz and screenshots of another issue with my card, which may relate to the issue I experience in my original post.

               

              A few observations/notes:

              1) I have certainly installed my card correctly to the best of my knowledge. It is firmly seated in its slot, and indeed, I have tried multiple slots and they all have the same issue. I have taken care not to damage the card or handle it improperly, particularly along the connecting strip.

              2) My graphics card is not recognised correctly in windows (perhaps?), but I have installed the correct driver.

               

              Could you please take a look and let me know of what your opinion is as to the problem? Is it a faulty card?

               

              Thanks again.

            • Re: Starcraft: Brood War Colour Corruption
              kingfish

              Have you tried running it in compatibility mode? (WinXP or Vista)