20 Replies Latest reply on May 24, 2017 10:44 PM by goodplay

    The color is too light from 17.4.4 to 17.5.2

    linjuzhou

      When up to the 17.4.4,I feel the color is too light, the problem still not be finished on 17.5.2, Don't you see that? The color is so beautiful on 17.4.3

        • Re: The color is too light from 17.4.4 to 17.5.2
          ebojager

          Not sure if this is helpful, but what I have had to do is goto the Radeon Additional Settings and set my Color Pixel Format to Full RGB and then make sure my TV is set to RGB Full or High or whatever your TV monitor has for that.

          1 of 1 people found this helpful
          • Re: The color is too light from 17.4.4 to 17.5.2
            spikeypup

            Linjuzhou,

             

            Ni-hao!  It is hard to say what could be the issue for you, ebojager is correct that checking this setting in "Radeon Additional Settings" control panel (access through Crimson Drivers Control Panel by clicking on Preferences and you should see the option for it) and ensuring that your pixel format is correct for your display.  Typically the drivers will set it to YCbCr when connecting through HDMI, and for most televisions acting as monitors this will work well or just fine, however if you are using a PC/Computer Display that connects via HDMI, you'll most likely see the best results with RGB formatting.  Whether your display can go Full or Limited is up to your display.  If blacks seem not dark enough and whites are kind of muddy, try RGB Full to remedy.  Most modern displays will be able to use RGB Full, you may need to enable it on your monitor as well (Full/Limited)  whichever it is, ensure it matches on both sides for the most accurate color display.

             

            One other thing to note, and the reason I decided to chime in on the topic is that some time ago, and I'm not sure when, my EDID PROM went bad in my monitor, causing the video drivers to use incorrect values for my pixel clock, this can/will lead to serious abnormalities in both color and clarity of display as well as frame stuttering and other visual issues.  My clock value was off by almost 30-40Mhz!  To fix the issue, after a good 6-8 months of trying to figure out what was wrong... I looked at the specifications of my display for all the necessary values to create a custom resolution profile that would utilize the MAX allowable clock at 1080P for my display.  After creating the custom resolution, my color issues (lack of vibrancy, bleed, etc.) were completely resolved, and sharpness/crispness was restored.  It also eliminated the appearance of judder and tearing at standard framerates that I was experiencing.

             

            Although my 2nd and 3rd displays were working acceptably, I repeated the procedure for those as well and have been treated to outstanding color, clarity and smoothness of rendering across all displays.

             

            So in addition to ebojager solution mentioned, also verify that what is displayed in the Crimson Radeon Settings --> Display --> Specs tab for your display matches one of the approved operating modes / resolutions for your display, paying careful attention to the pixel clock for the given resolution you wish to use.  Refresh rate is of course important but note that some displays can operate at different clock rates for a specified or given resolution and refresh rate, for example, my display does 1080P @ 60 Hz with 3 varied clock rates, I tested all of them and the best by far was the rate with the highest pixel clock, which was 173Mhz exactly.  Note that when the pixel clock changes but the displayed resolution stays the same, there will be a variance in either the refresh rate (59.***Hz vs 59Hz or 60Hz etc.) or the Horizontal and Vertical Timing TOTAL, this is not the same as Vertical and Horizontal Timing DISPLAY.  I've attached a sample using my display so you can see, I decided to leave the driver as the generic built-in windows driver, to avoid the monitor drivers forcing or overriding the EDID information and possibly causing issues with my custom resolution.  Also because the timing values provided by the driver are not the most optimal, but the most compatible, thus not allowing the monitor to work at it's best in terms of speed and color accuracy/resolution, but would allow it to work across the largest span of video adapters possible.

             

            Monitor Pixel Clock Configurations.png

             

            Another thing to verify is that you are using a color profile that is designed to work best with your monitor, typical sRGB profiles are OK, but generally you'll want to use the one made for your monitor from the manufacturer.  The driver is not required for this, ICM/Color Profiles work independently of the drivers for the display.  Color profiles are accessed through Display Settings --> Display Adapter Properties --> Color Management.

             

            Also be sure to reset your display settings to default as well to ensure nothing is set way off and you have a good balanced place to start making adjustments when all the core setup items are verified to be correct such as the above items like Pixel Format, and Display timings and ICM profile.  Windows can assist you in calibration as well with a calibration tool, also found in Color Management under the "Advanced" tab, simply click on "Calibrate Display" and follow the instructions.  Again, I wouldn't bother with all that until you first verify the Pixel Format settings are correct and the display timings  as well.

             

            Good luck!

             

            Spikeypup

             

            Standard Disclaimer:

            Please note all advice given above is an offered possible solution/explanation and may not fit your exact situation, issue, or dilemma.  The detailed solution/explanation may or may not solve your issue and is only offered as assistance in troubleshooting your particular issue.  Not all statements have been verified for accuracy or effect on all hardware types, as such  your mileage may vary with the presented information above.  Any implementation of the aforementioned is completely your decision and sole liability, I cannot be held responsible for any damage or issues caused as a result of any reader of this post utilizing this solution/information.

            1 of 1 people found this helpful
            • Re: The color is too light from 17.4.4 to 17.5.2
              kingfish

              Do you not have color management in the control panel?

              Screenshot_2.png

               

              Screenshot_3.png

              • Re: The color is too light from 17.4.4 to 17.5.2
                goodplay

                What OS/build vers./edition ?