4 Replies Latest reply on May 24, 2017 12:45 PM by amdmatt

    Rebooting while installing drivers (RX 580)

    banzai3030

      I just tried installing a Sapphire RX 580 Pulse, but as soon as I try to install the AMD drivers my screen goes black and the computer reboots.

       

      • Sapphire RX 580 Pulse 8GB

       

      • Desktop
      • Windows 10 Creators Update 64 bit

       

      • Driver version installed
        • None, tried 17.4.4, 17.5.2 and whatever version was on the included CD
      • Display Devices
        • Samsung UE850 28" 4K DP to MiniDP
      • Motherboard
        • Asus Maximus Ranger VIII
      • CPU/APU
        • Intel i7-6700k
      • Power Supply Unit  Make, Model & Wattage
        • Fractal Design Integra M 750W Plus Bronze
      • RAM
        • Corsair Vengeance LPX Black 2666M 2x8

       

      At first I couldn't run the installation software at all, just got a Windows-error message that atiadlxx.dll wasn't supposed to run in Windows and couldn't even start the installer.

      Then I somehow managed to get further on, but whenever it gets to the point of installing the actual driver, the computer reboots.

      I removed the RX 580 and booted up again, and managed to install the driver by running Windows update, but putting the card back in and booting up just reboots as soon as I log in to Windows.

      I've tried going into safe mode and removing every trace of previous drivers (I did not have a VGA card installed previously, just ran the Intel HD Graphics) using both DDU and the AMD Cleanup Utility, but every time I try to install the drivers again the same thing happens.

      I've tried the version included on the CD, 17.4.4 and 17.5.2, full versions and the minimal setup, and the AMD Chipset Drivers Software 17.10rcp22-apr27 and nothing works.

       

      I'm running the computer with the RX 580 now without any rebooting issues, but it's of course no fun at all running it with the standard Microsoft Display Driver

      What could possibly be wrong? I haven't managed to Google anyone with a similar problem...

       

      Thanks in advance for any advice