AnsweredAssumed Answered

Power Efficiency Off Causes Crashing In 2D Environment R9 390

Question asked by archilion2@gmail.com on May 20, 2017

Since Crimson 16.3 and the "Power Efficiency" toggle, R9 390 users, mostly wi Sapphire 390's, are experiencing crashes (TDR) IN 2D environment, when "Power Efficiency" is toggled to OFF. It's almost June 2017 and the problem is known since March 2016. That is 1 year and 3 months, people. Also you made the toggle switched to Off by default, which "crashed" many clueless users with 390's.

There are ONLY 2 remedies:

ClockBlocker by A2Razor - ClockBlocker Download Version 1.2-6.5

And turning Power Efficiency to ON.

And this IS JUST NOT acceptable. R9 390 is not a low end card from 2009 for it to be that much abandoned.

Suggestions:

I think it would be a great idea to introduce an option, that locks the GPU and Memory clock to the maximum possible, regardless of usage and/or to fix this problem with R9 390 users.

More threads about this problem:
Sapphire Nitro R9 390 memory clock fluctuations causing crashes (have to reboot)

Sapphire R9 390 only browsers causing Black Screen

Outcomes