5 Replies Latest reply on May 31, 2017 1:46 AM by amdmatt

    Reinstalled driver but games not working (R9 390)

    amitbecken

      Specs:

      • Windows 10 64-bit
      • R9 390 Windforce (approx. 1.5yo)

      Problem:

      I opened my computer today after 4 days of not using it, started playing some Overwatch when suddenly the game crashed with the message "rendering device has been lost".

      I figured it was a driver problem and noticed Radeon Settings has crashed as well, so I re-launched it. I tried re-launched Overwatch again yet suddenly the FPS was terrible - about 13 FPS instead of the normal 60~70 FPS. That's when I decided it's probably time to update my drivers cause something's gone wrong. The driver which I had - 17.1.1 - was indeed outdated, so I just went on to download the latest recommended driver which is 17.4.4. After I installed it game failed to start and raised the following error:

      "No compatible graphics hardware was found (0xE0070150)".

      I guessed this meant that something is going crazy with my GPU so I decided to try and remove all the drivers using Display Driver Uninstaller.

      After supposedly removing the drivers using DDU, in Safe Mode, I checked to see that the graphics device was no longer detected. Device Manager and MSI Afterburner showed that the main display adapter is "Microsoft Basic Display Driver" and CPUID HWMonitor showed that the only detected graphics device is Intel HD Graphics, so it seems like the drivers were uninstalled correctly.

      Then I tried reinstalling the driver, yet this time I tried installing Crimson ReLive 17.5.2 because I saw other people complaining in the Overwatch forums about problems with 17.4.4.

      Now, after installing 17.5.2, my GPU is detected by Device Manager, MSI Afterburner and HWMonitor altogether. Yet, when trying to launch Overwatch, the game still fails to launch and still raises the error which claims that no compatible graphics hardware was found.

       

      What do I do? Now I can't play anything - neither Overwatch nor Rocket League, and even iTunes warns me that now video playback is unavailable.

      Thanks in advance.