rad666a

"No suitable graphics devices found" error

Discussion created by rad666a on May 15, 2017
Latest reply on May 15, 2017 by rad666a

OS: Windows 10 pro 64 bit

GPU: Sapphire Nitro+ RX480 8gb

 

After installing driver version 17.4.4 periodically, when I attempt to launch a game, be it something simple like "Win7 Solitaire" or more complex like "Fallout 4" I will get an error. In the simple case, I get a dialog box that says "no suitable graphics devices found error". In the case of Fallout 4 the game will crash while attempting to load. The only way to fix the problem is to reinstall the driver, but it always returns. The error persists if I use 17.5.1. I have used Guru3d's DDU to remove the driver and clean install, I have physically removed and reinstalled the graphics card and the problem keeps coming back.

 

There are no error reports, crash dumps, or anything I can find to attach to this post but if you can tell me what to look for I will certainly try.

 

The only thing I have not tried is reinstalling 17.4.3 (which worked fine), but I will be doing that once I finish here.

 

 

Any help will be greatly appreciated

Outcomes