AnsweredAssumed Answered

Wolfenstein new order crashes at chapter 4 Eisenheim prison.

Question asked by williamgaatjes on May 15, 2017
Latest reply on Sep 3, 2017 by criskette

Hi, i hope you can help me out.

I bought a gigabyte RX480 g1 gaming card in december 2016.

And it works well. I have installed various games (dx8 up to recent vulcan based game) and benchmarks programs and no crashes or any issues.

Well, except one crash at doom 2016 at the end. But that is it.

But yesterday i have bought the game wolfenstein new order from steam. And i have exactly the same problems many owners with a RX470 or RX480 card have reported in the steam community.

See link :

Wolfenstein The New Order Eisenwald Prison crash. :: Wolfenstein: The New Order General Discussions


I have been playing the game for several hours without any issue. But it seems there is something in the game that crashes the game and /or the gpu crimson program.

This happens in the Eisenheim prison chapter (chapter 4) of the game, the game constantly crashes and i noticed the radeon crimson settings program crashes as well. I have to restart my pc to get radeon settings functional again.

The crash seems to happen mostly when the chains in the game become visible or other objects with a metal shine and that flash on and off (to emphasize that it is an object for the user to interact with) . Unfortunately, these chains play a vital role in the chapter. They must all be cut with a torch. And as soon as these objects come into the field of view. After a few seconds the game crashes often taking down the radeon settings program as well. I am not sure if the gpu driver crashes because the image does not go to black. The game just freezes and crashes.

I have tried turning all settings on and off in the game and all radeon settings for this specific game. Lowered the resolution. But to no prevail.

I read on the steam community that some have tried to rename the executable, which i can only imagine results in that the driver does not recognize the game and does not load specific optimizations for the game. I have come to understand that this is often the case to get games up and running for all pc based gpu manufacturers .

I can not try if this renaming fix mention in the steam community works since steam constantly verifies the files of the installed steam games.  And thus refuses the game to run when renamed. Which for game integrity i can imagine.

The game runs with the idtech 5 engine on opengl.

I should note, before the dreaded chapter 4, i had the game running on high settings with triple buffering enabled in the radeon settings. And at a resolution of 1920*1080p. vsync on. The game usually stayed at a stable 60fps with occasional dips to 45fps at wide open fields with busy scenery. But the image was fluid. No tearing, no artefacting, no stuttering. The game ran fine until chapter 4.

I did a steam file  integrity check as well and all files check out according to the steam program.


System specifications :

CPU: A10-6700 richland piledriver with internal gpu disabled.

MB : GA-F2A75M-HD2_V10. A75 chipset based with latest bios update.

RAM: 8GB DDR3-1600.

STORAGE: 256GB SSD + 500GB HDD. All error free.

GPU: gigabyte rx480 g1 gaming 8GB with latest bios update F8.

new 550W seasonic psu.

W10-64 version 1703. build 15063.296



Radeon Software Version 17.5.1

Radeon Settings Version 2017.0502.1417.23881

OpenGL® Version



Graphics Card Manufacturer - Powered by AMD

Graphics Chipset - Radeon (TM) RX 480 Graphics

Device ID - 67DF

Vendor ID - 1002

SubSystem ID - 22D0

SubSystem Vendor ID - 1458

Revision ID - C7

Bus Type - PCI Express 3.0

Current Bus Settings - PCI Express 2.0 x16

BIOS Version -

BIOS Part Number - 113-xxx-xxx

BIOS Date - 2016/10/26 08:49

Memory Size - 8192 MB

Memory Type - GDDR5

Memory Clock - 2000 MHz

Core Clock - 1290 MHz

Total Memory Bandwidth - 256 GByte/s

Memory Bit Rate - 8.00 Gbps

2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0000


I usually have the gpu running at a max boost clock of 10% lower than factory setting. Max temp control at 77C. And lowered voltage to max 1050mV. Never had any crashes.

To make sure this can not be it, i set all settings to the default settings in wattman. The issue remains with the gpu on default wattman settings.


I hope you can help us sad rx480 owners who really like to play wolfenstein new order.


Thank you in advance.