AnsweredAssumed Answered

AMD HD Audio HDMI not showing in Playback Devices after update

Question asked by sitanoni on May 14, 2017
Latest reply on Jul 14, 2017 by imno007

Hello everyone!


First time posting here, hope someone can help. I've searched through the web, and it seems lot's of people have the same issue, but nothing helps for me.


After updating Windows 10 and updating my AMD drivers to Crimson ReLive Edition 17.4.4 my Viewsonic monitor isn't recognized as a playback device and is gone from the device manager.

It used to be there as "AMD High Definition Audio Device", and I was using it to play audio through an HDMI cable.


I have encountered this issue before, and solved it by reverting back to the previous driver version, but now this doesn't solve it.

The only thing that works now is if the driver is uninstalled, this is why I think it is not a Windows issue. For example, when I reinstall the driver, right after it says "restart to take effect" the audio works and my monitor shows up in the playback devices. As soon as I restart my computer it's gone again:


With drivers before reinstalling:

After reinstalling (before PC reboot):

Then when i restart my PC it goes back to the 1st image.


It even disappears from the device manager, when the Viewsonic monitor should be there:



Things I tried:

-clicking "Show Disabled Devices" and "Show Disconnected Devices" in playback devices (nothing shows up except "Headphone - High Definition Audio Device - Not plugged in")

-reinstalling the driver

-reverting back to older version

-updating to newer version

-clean uninstall then install again

-uninstalling Realtek drivers

-uninstalling Razer Synapse drivers

-changing the HMDI ports on my monitor

-unplugging and plugging in the HDMI cable

-updating the drivers through Windows with device manager

-manually updating AMD High Definition Adio Drivers (unsuccessfull)



GPU - AMD HD 7970

CPU - Intel i7 3770

RAM - 24GB

AMD Driver - 17.4.4

Windows version - Windows 10 Pro 64-bit (version 1703, OS Build 15063.296)