3 Replies Latest reply on May 16, 2017 3:04 AM by amdmatt

    Problems with 17.5.1 and latest Win10x64 Insider build...

    waltc

      ...and VSR...I was disappointed immensely to see that when I tried to post to the original poster's question that my post suddenly was  "currently being moderated"-- for the last hour or so.  Plenty of time to read and "approve" a perfectly valid post.  So here is the post which I see nothing wrong with making and with which I cannot imagine any moderator having a problem with.   What's with this "moderation" stuff?  Are sincere problem reports no longer tolerated here?  What's up?  I hope not. Having end users discover and address problems is a valuable resource for AMD--as clearly I did not join the site yesterday and clearly this post is anything but a mindless flame--and neither was the OP's, either.  Sometimes searching through similar problems offers up valuable info--sometimes it is of no value at all, as I found in this case.

       

      (The following are just my observations about this problem. I haven't posted system specs here because I have already sent in a problem report through the Crimson interface. )

       

      I am having the same problem, unfortunately.  It's not clear where the problem is, really, because VSR works fine when setting desktop resolution via Display Properties--the VSR resolutions above native are all present and functioning--but only for the desktop UI and not from within games atm.  I'm running Windows 10x64 build 16193, and I've gone all the way back to 17.3.2 and VSR is not working--however, I couldn't actually try 17.2.1 because a) the link to the driver on the AMD previous driver site isn't working at all--link exists but there is no file attached to it, and 17.3.1 refuses to install to Win10x64 16193 because because of a "no signature found" error.  Really, if AMD is going to post previous drivers--which is an exceptionally good idea for obvious reasons, I'd prefer to see them retroactively fix the Win10 signature problems with those drivers, too.  Aside from fixing the previous driver links..;)

       

      Most people are already on Win10, and after 1/31/2020, which is the drop-dead-that's-all-she-wrote for any and all Windows 7 support, everyone will be on Windows10--with a few people still on Win8/.1, of course.  The real stampede to Win10 hasn't yet occurred, imo--that will happen beginning 2/2020 when Windows 7 blessedly dies its final death...;)  (Oh, Win7 will still "work" on some hardware still in use at the time, but driver updates, security patches and bug fixes will be over and done--"new feature support" for Win7 has already ended.)

       

      Anyway, I've tried everything possible--turning on GPU scaling with VSR enabled, turning it off with VSR enabled, etc.  Take the Witcher 3, 1.31 GOTY version, for instance,  a game in which you can set the resolution directly within the Witcher 3's C:\Documents\The Witcher 3\user.settings configuration fileBefore this week's install of version 1703, build 16193.1001 (a Windows-Insider exclusive build), and the 17.5.1 Crimson driver, all desktop UI VSR resolutions (3200x1800, & up for my 2560x1440 native monitor--my RX-480 is an 8GB model) could be set from within the Witcher 3 settings and all of them worked as advertised.  Last week, I was using Win10x64 version 1703, build 16188, I might add, along with the latest 17.4.x Crimsons--also a Windows-Insider exclusive build.

       

      Here is also some behavior I noticed with the non-working VSR 17.5.1's--when in Witcher 3 I have set the user.settings resolution configuration for 3200x1800 (or *any* of the VSR-enabled resolutions), I find that after the game loads and I peek at the game's internal resolution settings through Witcher 3 options,  that none of my VSR resolutions show up as present or selectable any longer.  But it is interesting that when I exit the game I can actually see the Win10 desktop UI switch from the VSR res of 3200x1800 down to the monitor's native res of 2560x1440.  Takes place in just 1-2 seconds, but the change from VSR to native res is plainly visible. So...

       

      It would appear that for some reason with the 1703, build 16193.1001 version of Windows 10x64, and the Crimson 17.5.1's (I loaded a couple of 17.4.x drivers as well that also displayed the same problem with VSR inside games), that for the Windows Desktop GUI,  VSR resolutions are working as advertised but that for some reason VSR support inside my games is broken.  For what it's worth this isn't much to add to the original post, but I concur...;)

       

      Interestingly enough, I noticed that in the SE of Skyrim (x64 version), the latest game version, that while VSR resolutions are present and selectable in the "options" menu that can be set from the Skyrim launcher (but not from within Skyrim itself), that even though the resolutions are all selectable when the game is run afterwards, the VSR resolutions do not display properly and the full screen is not rendered in-game--just a portion of it--which it makes the game unplayable, of course.

       

      I will add the caveat that all of this testing was done with the games in full-screen mode--have not tested in Windowed mode--that is my next stop...;)  Will come back and edit this post with the results of Windowed mode as it may or may not bear on the problem...

       

      Edit: OK, tested in Windowed & borderless modes for W3--same problem.  It's gets down to the Crimsons + or - there being a change inside the recent Win10x64 builds that is responsible...

        • Re: Problems with 17.5.1 and latest Win10x64 Insider build...
          goodplay

          "Links" get moderated now, the driver downloads page was recently modified (guess someone at amd hasn't checked that everything is working as was).

          That and the sig. problem for amdmatt  or ray_m

            • Re: Problems with 17.5.1 and latest Win10x64 Insider build...
              waltc

              goodplay wrote:

               

              "Links" get moderated now, the driver downloads page was recently modified (guess someone at amd hasn't checked that everything is working as was).

              That and the sig. problem for amdmatt or ray_m

              Thanks, I could not understand *what* was going on yesterday...;)  The previous driver page problem really didn't bother me...these things happen.  I was probably a bit short-tempered yesterday...;)  Easy to misunderstand things when I get a bit impatient...unfortunately.  I just had never seen the "under moderation" notice before--on some sites that sort of notification means the post will never see the light of day and it has effectively been censored. Glad to hear that is not the case here...!

               

              So...wondering who else is having the VSR problem with this build?  I've sent in a problem report but we still don't know if this is something relative to the 17.5.1 drivers or to a few Windows builds...or both...?  Came here this morning hoping that someone may have seen a fix somewhere...guess not, regrettably.

               

              Edit:  Wanted to add that I used the ignore driver signing option in Win10x64 16193 to install the 17.3.3 driver set--same problem, so I am back on 17.5.1.  Looks like it is definitely a Microsoft/AMD problem relative to certain Win10 builds, for some reason. I have also reported it to Microsoft on Win10 Insider's Feedback.