AnsweredAssumed Answered

Unable to run ~50% of games tried after installing RX-580 and updating drivers - any suggestions?

Question asked by stormwaltz on May 13, 2017
Latest reply on May 16, 2017 by stormwaltz
  • AMD Graphics Card: Gigabyte Aorus 8GB RX-580
  • Desktop or Laptop System: Desktop
  • Operating System: Windows 7 Home Premium (64bit)
  • Driver version installed: Crimson ReLive, I've tried both 17.4.4 and 17.5.1
  • Display Devices: HP Compaq LA2405wg
  • Motherboard: ASUS Sabertooth Z87
  • CPU/APU: Intel i5-4670 Haswell Quad-Core 3.4 GHz
  • Power Supply Unit  Make, Model & Wattage: Corsair RM 650W
  • RAM: 16GB


I bought a new card this week, cleaned out the old drivers, and installed the latest ones. Since then I've had mostly trouble. All non-gaming applications seem to work fine - Netflix, Twitch, movies on iTunes. Games are a crap shoot. I've attached screencaps of several error messages from the following:


Games That Won't Start / Crash on Load:

Star Trek Online, Star Wars: The Old Republic, World of Warships, Lord of the Rings Online, Guild Wars 2, Saints Row 3, Stellaris, The Secret World, Age of Conan, Sid Meier's Pirates


Games That Run, But With Errors:

Just Cause 3 (stuck in windowed mode, can't set monitor res in options), No Man's Sky (stuck in widowed mode), Shadow of Mordor (loads fine, crashes during benchmarking), Skyrim Special Edition (setup said, "Your video hardware was not identified," but ran fine after manually setting to "ultra" quality)


Games That Run Fine:

Elder Scrolls Online, Civilization VI


All of these games are auto-updated through Steam or their own patching software, and are most-current versions.


I've tried cleaning out old drivers using Guru3D's DDU, and reinstalling from scratch. I've tried reinstalling DirectX, but the installers insist I have a "newer or equivalent" version installed already.


(Edit: cleaned up typos, my apologies)