2 Replies Latest reply on May 13, 2017 1:19 AM by poweruser

    No game will launch after 17.3.3 driver update

    poweruser

      System Info:

      Graphics card: Radeon R7 260X

      System: Desktop PC

      OS: Win10 x64

      Driver version: Radeon Crimson ReLive 17.5.1

      Display device: BenQ G922HDL 1366x768 @60Hz DVI-I

      Motherboard: Asrock H81M-HDS

      CPU: Intel Core i3-4160 @3.6GZ

      PSU: Zalman ZM600-LX 600W

      RAM: 8GB

       

      Everything used to work a month or two ago. Back then my driver was 17.3.3. Then an update came and made my games unplayable (literally no game or 3D software will run on my PC unless I downgrade to 17.3.3). I uninstalled then reinstalled, same problem. It seems games can't detect my video card - they crash with a message like this: "No graphics device was found". Then I tried DDU and downloaded 17.4.4. I installed it and it worked. But when I updated to 17.5.1 - same issue. If I have to use DDU every time an update is available... I'll just downgrade to 17.3.3 and disable updates altogether.