7 Replies Latest reply on May 20, 2017 3:21 AM by goodplay

    R9 390 Fan Speed Stuck at 2500 rpms

    dangerpanda

      I have tried to change my fan speed using Wattman and MSI Afterburner. In each program the fan speed can not be controlled. I have made sure to set the fan speed to manual and click the apply button. Any change I make is ignored and Wattman cannot says my fan speed is at 0. For some reason unplugging and re-plugging in the graphics card will fix the fan speed for a short period of time.

       

      • Graphics Chipset: AMD Radeon (TM) R9 390 Series
      • Desktop
      • OS: Win 10 Pro 64 bit
      • Radeon Software Version: 17.4.4
      • Display:  Acer 60 hz
      • MOBO: ASRock
      • Processor: Intel(R) Core(TM) i5-4460
      • PSU: EVGA 500 W1,
      • RAM 8GB

       

      Thanks you in advance for any help

        • Re: R9 390 Fan Speed Stuck at 2500 rpms
          adamd16

          I had a similar issue a while ago with rx 480 however the issue you're describing was fixed in driver patch, I suggest you delete any old amd driver files (where previous installers might be) and use a program called DDU (Display Driver Uninstaller) - Display Driver Uninstaller (DDU) V17.0.6.5 Released. | Wagnardsoft  (I believe this is the lastest version) to clear the current install of the amd driver you have and then download the latest version - Download Drivers . Once you've followed those steps go to Amd wattman section and adjust the fan speed to something like 1500rpm and you'll notice the difference.

          • Re: R9 390 Fan Speed Stuck at 2500 rpms
            goodplay

            Running Wattman with 3rd party OC apps. are known to conflict with the newer drivers.

            The fan control in wattman for 390s' is a fixed speed(last time i checked), and also does not show correct current speed.

            Your options are to use only wattman(other oc apps uninstalled), with fan on auto.

            Or disable wattman to use other oc app.

            To disable wattman, reset other oc app to default(and disable/uninstall it), reset wattman to default.

            Then in Radeon settings, go to Preferences > Restore Factory Defaults(it will restore all setting, so make note of other graphics/game profile settings).

            It should now show,

            disable wattman.PNG

            Do not enable/accept it again, enable/reinstall other oc app.

            There are an odd few who say this does not work for them. Possibly could be leftover files, a Clean Install AMD Graphics Drivers may be required if you run across that issue.

            1 of 1 people found this helpful
              • Re: R9 390 Fan Speed Stuck at 2500 rpms
                dangerpanda

                Thanks for the suggestion goodplay, I appreciate it. After following your directions and reinstalling the drivers, it looks like MSI Afterburner can "set" and "read" the fan speed now. Unfortunately setting the fan speed does not seem to actually change the physical fan speed. Setting the fans to 99% sounds the same as 25%. Any other thoughts?

                  • Re: R9 390 Fan Speed Stuck at 2500 rpms
                    goodplay

                    I do not use fixed speed (auto for general, custom curve for high demand games).

                    Need more details on whether prob. is when on idle(desktop), and or gaming/video, etc..

                    Disable all non-windows progs./apps. from Task manager > Startup. Disable minimized apps/web pages on start up. Disable HWacc. in browsers.

                    What Temp/fan speed readings are showing in GPU-Z, HWINFO64 on idle.

                    Most PSU recommendations for the 390 are 550-600 to 750W(your psu peaks @480), depending on exact graphics card make/model.

                    That could be a factor, also possible is the card fan controller has become defective.

                    1 of 1 people found this helpful