8 Replies Latest reply on May 18, 2017 1:29 AM by amdmatt

    [RX 580] Blinking monitor under certain loads

    bdayz

      Hello! First time poster and also first time AMD product user!

      Unfortunately it's not going so well for me..

       

      So I'll just follow the post model, right now.

      AMD Graphics Card:

      • Gigabyte Radeon RX 580 Gaming 4G

      Current OS: Windows

      • 10 64bit (version 1703)

      Driver version:

      • 17.5.1

      Display Devices:

      • LG TV (1360x768, 60Hz) connected via direct HDMI (2nd monitor)
      • Asus VS228DE (1920x1080, 60Hz) connected via Displayport to VGA with a Converter Adapter (main monitor)

      Motherboard:

      • MSI Z170A PC MATE

      CPU:

      • Inter Core i5 6600k

      PSU:

      • XFX TS 550W (XXB9)

      RAM:

      • 16GB

       

      Description: I've come across a really annoying problem that I have yet to determine the cause. My main monitor, which is connect via a DP to VGA converter, goes blank - as in the screen turns black (doesn't lose signal) - when under certain loads.

      First time I saw this issue I had just launched FurMark. As soon as I launched it the screen blinked once and came back. Didn't think much of it at the time until it blinked again, 3 seconds later. Then it kept blinking for the whole duration of the test, randomly - see attached video for visual aid.

      I restarted the computer, uninstalled the drivers, rebooted again, reinstalled them. Tried again. Same thing. I then literally formatted my PC, reinstalled everything and tried again. Same thing.

      I then thought it could be FurMark's fault so tried with MSI Kombustor. All well. GPU ran at max load, max clock like it should and no blinking. Then I installed 3DMark. It blinked again. A lot.

      I unplugged my monitor from the DP and tried it in the other 2 remaining ports. No change. I downloaded CS:GO and altough it was rare, it still happened. Then tried with Forza Horizon 3. It blinked once in a while for the first 30 minutes then the screen literally stayed black for a whole 20 seconds until I paused the game and it came back. Unpaused it and it went black again.

      Formatted the PC again and went onto Win7 and downloaded FurMark. Again, blinking. Went back to Win10, unplugged my main monitor and tried on my LG TV.

      It didn't blink BUT the brightness went down when I started FurMark up. Then back to normal as soon as I stopped the test.

      Finally, today, before I started writing this, I unplugged my LG TV and tried my main monitor solo. Still happened so most likely not a dual monitor issue.

      Also tried 2 versions of drivers, updated everything in my computer and reset every overclock I had made - take note I did NOT overclock the GPU at any point.

      One thing I have noticed is that it seems to happen when the clock isn't stabilized - In FurMark the clock is around 1200Mhz and goes up and down. In Kombustor the clock is stuck at 1340Mhz (stock clock for my card), but take this last piece of information with a grain of salt.

      As of right now I'm considering buying a new monitor with a displayport but I'd love to hear some opinions on this issue before doing so. You never know... Maybe there's some more troubleshooting left to do that will fix my issue without me spending any more money.

       

      Finally, like suggested, attached is a small video of the issue.

       

       

      Thank you very much for your time!

      Sincerely,

      Bruno

       

       

      Update(1):

      May 12th, 2017

      Ran MSI Kombustor with the FurMark test preset and although the core clock wasn't stabilized it did not cause any screen blinking.

      Tried running FurMark with fans at 100% making the temps not go above 55ºC;

      Lowered the Power Limit % to -25 and then upped it to +50. It blinked in these before mentioned runs.

      Finally I downclocked my card to 1200Mhz core clock and 1500Mhz memory clock. Still blinked.

      I have yet to up the clocks or voltages.

       

      Update(2):

      May 13th, 2017

      So I think I have pin pointed the issue... I was watching a youtube video earlier today and I saw some artifacts on the screen. For all I know artifacts are mainly (if not only) memory related.

      So like the stubborn idiot I am I went back to MSI Kombustor and loaded the GPU memory burner test. Lo and behold, the screen blinked. Loaded GPU core burner and it didn't.

      I tried lowering the memory clock to 1100MHz (from 1750 stock) but the screen still blinked during the test.

      Right now, I'm honestly out of ideas... But at least I think I've found the issue.

      Now for anyone reading. Would it be fixable? Or should I ask for a replacement?