AnsweredAssumed Answered

R9 390X weird problem(maybe drivers issue)

Question asked by georgex on May 11, 2017
Latest reply on May 18, 2017 by sharindel

Hello,

my vga is Sapphire R9 390X SAPPHIRE Technology and i have problems when i try to lauch pc games.I cant run any game at all.Especially when i try

to run a game it crashes.Even when i try to play World of Warcraft or Diablo it says that my pc dont have the minimum requirements.Even Mame dont load,it crashes with an error.I cant even run 3d Mark 11 or Vantage.

I encounter these problem with 17.xxxx series of amd drivers.With the 16 series all work pefect.Now i have installed 16.6 drivers and all are ok.

I have Windows 10 64 bit Home with the latest update and all my pc drivers are up to date.My pc specs are

Cpu:I7 3770K+Corsair H100,Mobo:Asus P8Z77-V Deluxe,Ram:32 GB DDR3 Kingston Hyper X Fury+Kingston Hyper X Fan Blue,Vga:R9 390X,Psu:Corsair AX 860i,Keyboard:Logitech G19

Are 17xxxx amd divers faulty or incomatible with R9 390X and Windows 10?

Please help.

 

Update:Ι installed 17.1.1 and it worked instead of other versions of 17.xxx

From the menu of Radeon Settings i checked for updates and i installed the 17.5.1 drivers through the Radeon Settings and finally it worked pefect and all isues were fixed.

If i unistall the 17.5.1 and try to do a clean install all the problems occur again.Only the update through the menu of Radeon Setting from 17.1.1 to 17.5.1 works without problems.This must be a driver bug...

Outcomes