AnsweredAssumed Answered

No games will start after switching from NVIDIA to AMD

Question asked by twiik on May 11, 2017
Latest reply on May 15, 2017 by twiik

TL;DR: I switched out my existing NVIDIA GeForce GTX 680 with an AMD Radeon R9 290X and now none of my games will run. If I switch back to the NVIDIA card everything works perfectly fine, just as it used to. I have tried everything!


I have a fairly old computer, the specs are as follows:

CPU: Intel i7-970

RAM: 24gb


Motherboard: ASUS P6X58D-E, Socket-1366

PSU: Corsair HX 750W

Operating System: Windows 7 Ultimate 64-bit Service Pack 1

Monitor: Eizo FlexScan S2431W (1920x1200)


It has worked perfectly for 5-6 years now, almost never rebooted, never blue screened, absolutely stable. It still works perfectly, but a coworker gave me his old computer which is about 50% faster in 3dmark than mine. It includes an AMD Radeon R9 290X 8gb from MSI. This computer is a prebuilt HP machine and it has basic unnamed components apart from the GPU. It has Windows 10 Home, an Intel i7-3770K CPU and 12gb ram.


I don't want to reinstall all my programs so I thought I could just move the GPU from this new machine into my existing machine, but all my attempts at this have failed. My games flat out refuse to run on the AMD card. These are the messages I get:


Diablo 3: "Your video card isn't supported for Diablo III. For reference, you have: Operating System Windows 7 Service Pack 1, Video Card: AMD Radeon R9 200 Series"


Counter-Strike: Global Offensive: "Just won't start, no message."


Borderlands 2: "Has stopped working" immediately when I click play.


Fallout 4: "Has stopped working" immediately when I click play.


Sniper 4 Elite: "Directx 11 failed to initialize"


GTA 5: "Unable to initialize DirectX 9 device"


The ONLY game that runs is DOTA 2, which I don't even play. I just installed it hoping that installing a game with reinstall directx or something and fix my issues. BUT it only works if I add "-dx11" to the launch options. Otherwise it shows a message: "Unable to find a valid Direct 3D device!".


As for what I have done in order:


1. When I decided I wanted to try putting the AMD card in my machine I just turned the computer off, removed my NVIDIA card, inserted the AMD card and powered it on. Then I downloaded the latest drivers and rebooted.


2. After not having any luck starting my games I started uninstalling everything related to NVIDIA. At this point I found information on Google which lead me to believe I should have done this before removing the NVIDIA card, but this information was conflicting, a lot of people claimed there was no issue having both drivers at once.


3. Still nothing worked so after some more googling I turned on Windows Update and downloaded and installed every available update (I have never run Windows Update on this machine before because if something works perfectly, then changing it can only make things worse).


4. Installing every possible Windows Update made no difference and a lot of my games were complaining about directx (see below) so I tried reinstalling it, uninstalling it, removing it from the registry, adding it back in. Nothing worked so I just restored it to how it was before I started fiddling with this.


5. At this point I thought I would try doing the process properly from the start so I downloaded a program from Guru3D for completely uninstalling graphics drivers and I ran that both for AMD and for NVIDIA. Then I followed a guide and deleted every folder or entry in my registry refering to NVIDIA or AMD.


6. I then turned off the computer and removed the AMD card and inserted the NVIDIA card.


7. I downloaded the NVIDIA drivers and verified that all my games worked just as well as before. This also verified that there's no issue with directx and that installing all those windows updates didn't change my system.


EDIT: And I also put the AMD card back into the new computer and verified that it still worked and that it ran just as well as before by running 3dmark and getting the same score.


8. Then I uninstalled the NVIDIA drivers again and did the same as in 5. to make sure every reference to NVIDIA was gone.


9. I then turned off the computer, removed the NVIDIA card and inserted the AMD card.


10. I downloaded the AMD drivers again and installed them.


11. This is where I'm at now. Still no games work except for Dota 2 with the "-dx11" launch option, which I don't even play.


I have no idea what to do now, what is left to try? I use OS X and Linux at work and there it is actually possible to fix something. With Windows it feels like if something doesn't work the only fix is to reinstall. That is my absolute last resort, in fact I won't do it. I will just put this AMD card back into the new computer and use that one if I need to play a demanding game, I guess.


But so many people online write about how effortless you can switch between NVIDIA and AMD or vice versa so obviously this has to be possible. And my computer still works perfectly. I'm writing this post on it. It has never failed to boot with the AMD card, it has never blue screened or crashed, and no games have crashed, they just won't start. The card is detected. I have no integrated graphics of any kind. dxdiag confirms that I have directx 11 and that the card is detected. 3dmark confirms that the card is detected, Diablo 3 confirms that the card is detected, the Radeon settings applications confirms that the card is detected. And the fact that DOTA 2 runs and runs perfectly well at around 120fps with everything maxed out should confirm the card works well.


Seriously, ***?!


Message was edited by: Øyvind Strømsvik