7 Replies Latest reply on May 15, 2017 3:19 AM by amdmatt

    New Radeon Driver Causes DirectX 9 Games to Not Work

    ocasta

      I recently installed the 17.4.4 driver update and now none of my Paradox games (Crusader Kings 2, Europa Universalis 4, Stellaris) work. When I try to start any of them, I get the following error message: "Failed to create a graphics device. Exiting."  I've searched this error message and it seems to indicate a compatibility issue between graphics card drivers and DirectX (in the case of these games, DirectX 9).  I've tried reinstalling DirectX 9, updating the Radeon drivers to 17.5.1, downgrading back to 17.4.4 (in both case, I did a clean install), and verifying the integrity of my game files for good measure. None of this has worked.

       

      Here are my specs:

      Graphics Card: AMD R9 290 (desktop system)

      OS: Windows 10 64bit

      Driver version: Radeon Software Crimson Edition 17.4.4

      Display: HP x220LED (connected with DVI)

      Motherboard: Gigabyte GA-F2A78M-D3H

      CPU: Athlon X4 860K Black edition

      Power Supply: EVGA SuperNOVA 750 B2

      RAM: 14 GB