My Ryzen 1800X Upgrade Diary

Discussion created by black_zion on May 5, 2017
Latest reply on Nov 11, 2019 by hardcoregames™

Thread best viewed with the linear, chronological layout, not that default forked mess that links replies directly to posts.



So, decided to clean up the thread and remake it, and basically detail my journey. I had been using the following system for a while:


ASUS Sabertooth 990FX Gen3/R2

AMD FX-8350 @ 4.6ghz w/ Corsair H105

24GB G.Skill DDR3 2133

Sapphire Fury Nano

1TB Samsung 850 Evo (Boot & Media)

512GB Samsung 850 Evo (Games)

240GB OCZ Vertex 3 (Online backups)


I had decided to upgrade to Ryzen given the much improved IPC capability, and had actually ordered everything a couple of months ago, but when Microsoft said


soup nazi - Ryzen? you think you can use ryzen? no updates for you!


I returned them and basically had resigned myself to using what I had until it blew up. Couple months later and Unofficial Patch Unblocks Windows 7 and 8.1 Updates for Kaby Lake, Ryzen came out which removed the update blocks, which were literally just "is_processor_supported" tags in the Windows Update file, which made Ryzen viable again. I had decided to wait for the 4 core 8 thread processors next month, but I figured when it comes time for resale the 1800X would hold its value better, I decided to take the leap again, and went with


ASUS Prime X370-Pro

AMD Ryzen 7 1800X

Corsair Vengeance LPX 16GB DDR4 3200

Samsung 960 Evo 250GB NVMe SSD


I decided to also go ahead and upgrade to a Samsung 960 Evo 250GB NVMe boot drive since I had to reinstall Windows anyway, so it'd be the best time to do it. I wanted to get the 1TB version, but it's $430, and I couldn't justify that considering what I was already spending. I also decided to go with Saturday delivery so I could hopefully get the system built and bughunted before the workweek. Well, Saturday came, FedEx came, got my tower tore apart, went to put in the CPU, and the box was EMPTY! The bottom seal was also cut, so I assume either someone in the warehouse didn't properly check a return or someone in the warehouse stole it. Nice little conversation with Amazon later, and a couple of days since they couldn't get a replacement to me until Monday, and I'm finally setup to go.


Or I thought I was. Windows 7 Setup would not capture my mouse or keyboard no matter which port I had it connected to or even if I used the PS/2 connector. Multiple keyboards and mice tried later, as well as some expletives, I decided to go ahead and try Windows 8.1, I had a copy I got for cheap. I had considered trying it first since it has 3 more years of support over 7 plus native NVMe support, but as there were no Windows 8.1 drivers mentioned I was afraid it didn't work, but it did just fine, and everything installed with drivers. I went ahead and started installing my programs and moving my media to my external drive so I could format my 850 Evo 1TB and use just as a media drive, but when I went to format it, it wouldn't format, not in Samsung Magician (secure erase), not in Windows, and not even in the bootable USB that Samsung Magician creates. Turns out that Windows 8.1 had just attached itself to the existing bootmgr despite being installed on a completely new drive, it still relied on Windows 7, and it also broke Windows Update.


3 drive images and Windows 8.1 setup again, I deleted all partitions on all disks and started from scratch, and this solved all my problems. Installed a gig or so of updates using WSUS Offline Update, and still had about a gig more to download from Windows Update, the patch worked like a charm. Thanks to most programs using %AppData% for data storage a simple copy and paste from old to new meant I had little to actually configure, didn't lose emails or anything. Game re-installation was what I was most worried about, but the bulk of them I repurchased on GoG, and since their installs were still in place on my games drive (restored from image), all I needed to do was scan and verify to get them up and going, took all of 300mb, though it would be much easier if GoG Galaxy had a "Verify/Repair All" button. Some games aren't actually installs, such as Doomsday, and some of them I haven't bothered to reinstall yet.


It's 5 days later and I'm remembering how nice it is to have a computer that just works. My RAM doesn't run at full speed yet, still waiting on ASUS to release an AEGSA update. Overclocking to 4ghz was easy, though it won't stabilize any higher, which is in line with the reviews that Ryzen tops out at 4-4.1ghz, but with the much improved IPC capability it's still a great gain.


I left out a few things, but basically that's how it went. I'm still dealing with a few idiosyncrasies and bugs in Windows 8.1, namely the "This PC" tile on the start screen changing to "computer" and a different icon, and it scares the heck out of me that AMD seems to be dropping Windows 8.1 support just as RX Vega is about to be released, not that the Fury Nano is a slacker in the graphics department I would just hate to see me have to nurse this thing for 6 more years or longer.