0 Replies Latest reply on May 5, 2017 7:17 AM by davdeveloper

    4GB Sapphire Radeon R9 270X unexpectedly shutdown

    davdeveloper

      PC Informations

      - 8 GB RAM

      - Windows 10 (latest version)

      - AMD Drivers (latest version - successfully installed)

       

      i have a issue with my 4GB Sapphire Radeon R9 270X card

      I bought a new mainboard yesterday H97 D3H gigabyte

       

      After I installed the graphics card to the new mainboard ...  I only saw blackscreen ..

      I found this post on the internet what is may be exactly my issue

       

      R9 series GPU & Gigabyte Motherboard possible incompatibility - [Solved] - Graphics Cards

       

      I have done the following:

      ,,motherboard's BIOS and in PCIe slots settings I turned from EFI to Legacy support"

       

      I only have found the setting ,,Other PCIe devices .... turned from EFI to legacy

       

      My graphics card was then recognized, I could play for 10 minutes ... Then again .. Blackscreen ..

      Does somebody has any idea ? Because the graphics card worked without problems before exchange ..

       

      Thanks