6 Replies Latest reply on May 8, 2017 6:56 AM by mack0y

    CS:GO unplayable with AMD FreeSync enabled, fine when turned off.

    tilor

      Hi everyone,

       

      I just got a new ViewSonic XG2401 monitor which supports FreeSync and has a 144Hz refresh rate.

      I was able to flawlessly enable AMD FreeSync in my Crimson settings after enabling it in my screen's OSD.

      Afterwards I set the monitor refresh rate to 144Hz in windows.

       

      In CS:GO I capped the frames using fps_max to 144 since the FreeSync range on this display is 48Hz-144Hz.

      The game becomes unplayable, I have constant stuttering and some flickering even though the FPS stay between 142-144.

      It feels like I'm lagging but my ping stays around 28ms.

      CS:GO isn't the only game I have issues with. In Overwatch I get increased screen tearing ironically.

      Once I disable AMD FreeSync in the Crimson settings everything runs smoothly.

       

      System info:

      CPU: Intel(R) Core(TM) i5-4460  CPU @ 3.20GHz

      GPU: SAPPHIRE NITRO Radeon R9 390X 8G D5 with Back Plate

      Mainboard: Z87-G45 (MS-7821)

      Memory: 16 GB DDR3 1600MHz

      OS: Windows 10 Pro x64

      Radeon software version: 17.4.4

       

      Additional screenshots to confirm settings: http://imgur.com/a/J0Xdl

       

      Any help is welcome.

      Thanks in advance!

        • Re: CS:GO unplayable with AMD FreeSync enabled, fine when turned off.
          tilor

          I would like to add that the 17.4.4 release notes state:

          Counter-Strike™: Global Offensive and World of Warcraft™ may experience flickering or performance issues the first time the game is launched on a system boot with AMD FreeSync™ technology enabled. Workarounds include exiting and restarting the application or task switching (alt+tab) in and out of the game to fix the issue.

          I have tried this but non of the suggestions worked.

          • Re: CS:GO unplayable with AMD FreeSync enabled, fine when turned off.
            mack0y

            I have the same monitor.  Tried some CS:GO and didn't have any stuttering with Freesync on.

            Try to disable stereo headphones (HRTF) in CS:GO

            Do you have flux?

            Do you have FRTC enabled?

            Did you try with the second monitor disabled?

            Can you try the Freesync demo and check if there is stuttering there?

            1 of 1 people found this helpful
              • Re: CS:GO unplayable with AMD FreeSync enabled, fine when turned off.
                tilor

                mack0y wrote:

                 

                I have the same monitor. Tried some CS:GO and didn't have any stuttering with Freesync on.

                Try to disable stereo headphones (HRTF) in CS:GO

                Do you have flux?

                Do you have FRTC enabled?

                Did you try with the second monitor disabled?

                Can you try the Freesync demo and check if there is stuttering there?

                Thanks for your reply.

                I tried turning off HRTF.

                Don't use flux.

                I don't use FRTC used the ingame fps_max command.

                Disabled my second monitor as well.

                The Freesync demo (windmill) seems fine.

                Also I had constant flickering in CS:GO.

                  • Re: CS:GO unplayable with AMD FreeSync enabled, fine when turned off.
                    mack0y

                    Probably it's not going to make a difference but try to install the Viewsonic drivers.  I have them installed.  They will fail to install using the installation wizard.   Either run the setup once and a folder will be extracted to the C: drive or extract the executable with 7-zip.  Then install the driver  from device manager using 'Have disk' and search for the extracted folder.

                    In the Freesync demo, using the red test pattern, do you notice any stuttering with just Freesync on and no Vsync?

                    In Overwatch, try to limit the FPS to 143/142 if you haven't tried already.  I also get tearing in Rocket League if I limit the FPS to exactly 144.

                    I also get flickering with Freesync but only noticeable in dark static backgrounds like in menus for me.

                    Also to make sure that Freesync is actually working, check the refresh rate from the Information menu in the Monitor's OSD while in the demo or playing a game with a variable FPS.

                    1 of 1 people found this helpful
                      • Re: CS:GO unplayable with AMD FreeSync enabled, fine when turned off.
                        tilor

                        Hi mack0y. Thank you so much for your help!

                        Just wanted to let you know my issue has been fixed.

                        I don't know specifically what did it but these are the steps I followed based on your suggestions.

                        • Install monitor ViewSonic drivers through device manager.
                        • Double checked if FRTC is disabled
                        • Limited fps to 142 in CS:GO and Overwatch (using the ingame options, not frtc)

                        Additionally I did:

                        • Updated onboard GPU Intel HD drivers based on other recommendations
                        • Uninstalled any Razer SDK and Synapse 2.0 (since I used a razer mouse)

                         

                        I do still notice a little flicker now and then but it's far from the gamebreaking experience I had before.

                        I also checked the refresh rate on my monitor's OSD. In CS:GO it tends to fluctuate between 139Hz and 143.9Hz.

                        On overwatch it's set at 143.9Hz.