2 Replies Latest reply on Apr 29, 2017 8:36 AM by ray_m

    Drivers past 16.11.5 not working /w RX 480

    majorp

      Hello AMD Community,

       

      I have a problem with the AMD drivers.

      Every time I try to install one of the ReLive drivers (basically any driver past 16.11.5) it wont work.

       

      The installation process finishes without any errors but when I restart my PC, it seems like it wont recognize my RX480.

      The resolution does not get set automatically (like it normally does) and when I try to open Radeon Settings it just says "No AMD graphics driver is installed,or the AMD driver is not functioning properly,Please install the AMD driver appropriate for your AMD hardware".

       

      I tried many versions of the ReLive drivers (both WHQL and non-WHQL) but none of them works. When I use the older Crimson drivers (16.11.5 and older), everything works fine.

      This is how I tried to install the new drivers:

      - I always did a clean remove via DisplayDriverUninstaller (DDU) first and then ran the newest driver installer from the homepage - with no success.

       

      These are my system specs:

      - Windows 10 Pro x64, all Updates installed including Creators Update (Build 1703)

      - XFX RX 480 8GB (Reference Edition)

      - Intel i5-3470 CPU

      - Gigabyte GA-B75M-D3H Rev. 1.1 Mainboard

      - 2 x 4GB DDR3-1333 CL7 RAM (G.Skill)

      - 250GB SSD Samsung Evo 850

      - 3TB HDD 7200 RPM Toshiba

       

      If you have any ideas how to fix my problem, please let me know. All help would be really appreciated.

       

      Thanks in advance.

       

      Greetings from Germany,

      MajorP