AnsweredAssumed Answered

Only 17.2.1 appears to work for my 295X2

Question asked by culbrelai on Apr 28, 2017
Latest reply on May 3, 2017 by amdmatt

System specs:

 

i7 6700k (unoverclocked)

ASUS MAXIMUS VIII HERO

XFX Core Edition Radeon R9 295X2

Corsair AX1200 Gold 1200w PSU

16 GB Corsair Dominator Platinum DDR4 at 2600mhz iirc

Windows Server 2016 Datacenter

 

It seems only 17.2.1 appears to work correctly on my system (using Windows 10X64 drivers since it is functionally identical to Server 2016, just without all of the ScamDrive, Windows Store, Cortana, etc...)

 

Tried to update to the most recent version (17.4.4) and the non-beta version 17.4.3 as well. Tried a clean install both with DDU and AMD's utility. Fails to detect my graphics card, while the older 17.2.1 installer finds it and it works perfectly. The log file should show all of my various attempts.

 

Got any clues or am I just stuck with it due to my somewhat unconventional choice of OS? Why would one version of a driver work and another not?

Attachments

Outcomes